Support » Plugin: Jetpack by WordPress.com » Twitter sharing now includes "via @jetpack" – how to get rid of this?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Although there is no current UI for changing the Twitter site tag, this can be modified using a filter.

    See: http://kopepasah.com/tutorial/change-jetpack-3-0s-default-twitter-card-site-tag/

    Thank you so much!! This works perfectly.. The only problem is that I don’t have a Twitter account so it seems kind of silly to have my blog name as showing ‘via @myblogname’ when I don’t even have a Twitter account. I guess it’s better than it saying ‘via @jetpack‘ though.
    Do you know of any way to completely remove the ‘via @…’?? That would be ideal.
    Or, do you of any way to remove the @ symbol? That way it could at least say ‘via myblogname’, so it doesn’t make it seem like I have a Twitter account when I don’t.
    Again, thank you so much for your assistance.. really appreciate it.

    Not only does the “via @jetpack” need to go away, but the additional advertising in the popup window that doesn’t automatically close after the tweet is submitted. Getting rid of clutter like this was one reason I moved to a self-hosted WP installation. These kinds of things should either be opt-in from the UI or not included at all.

    esmi

    (@esmi)

    Forum Moderator

    @mjvito: If you require assistance then, as per the Forum Welcome, please post your own topic instead of tagging onto someone else’s topic.

    lilacsun,

    Yes, there is an easy way to disable the Twitter cards altogether.

    See: http://kopepasah.com/tutorial/disable-jetpacks-twitter-cards/

    Hi Justin!

    Thank you very much for your help, but this only seems to remove the Twitter stuff from the Open Graph area in the header section.

    Is there a way to completely remove the ‘via @…’ when someone shares a tweet that appears on the tweet itself?

    Thank you again!

    Marking this topic resolved since this was resolved with the latest update. Thank you so, so much! Best regards. 🙂

    Plugin Contributor Brandon Kraft

    (@kraftbj)

    Happiness Engineer

    Sorry about that folks. We made improvements to the Twitter cards, including an option in the user interface via Settings->Sharing to declare your own Twitter account as you had to use the code mentioned before.

    In doing that, we slipped and let the “via @jetpack” get shipped as the default. I’m sorry about the oversight. 3.0.1. removed it so it won’t say via @jetpack unless you explicitly say to do that 🙂

    Cheers!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Twitter sharing now includes "via @jetpack" – how to get rid of this?’ is closed to new replies.