WordPress.org

Forums

Revive Old Post (Former Tweet Old Post)
[resolved] Twitter Redirect Loop (8 posts)

  1. KimJCastleberry
    Member
    Posted 2 years ago #

    Every time I try to authorize twitter, even in different browsers, after I input my name/password, the browser tells me that the page has a redirect loop. Some googling indicates this may be due to a problem with the specified callback url.

    "The page isn't redirecting properly
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

    "This webpage has a redirect loop
    The webpage at https://api.twitter.com/login?redirect_after_login=%2Foauth%2F%26TOP_oauth%3D1%3Foauth_token%3DGdoztdkr2cNqYczPxTnVsr2Qr5k6hc32V9p0vUbncQ%26oauth_verifier%3DHkugAh9au5NDI6FUYXWum3izhhcBdJrdBeOUsWBJXw has resulted in too many redirects.
    Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects."

    http://wordpress.org/extend/plugins/tweet-old-post/

  2. akhawatebusiness
    Member
    Posted 2 years ago #

    Hi,

    me too i have exactly the same problem

  3. liannemurphy
    Member
    Posted 2 years ago #

    Hi guys,

    Same here. Has anyone worked out the solution?

    Thanks

  4. KimJCastleberry
    Member
    Posted 2 years ago #

    I've still not found a solution :(

  5. liannemurphy
    Member
    Posted 2 years ago #

    I've gone with a similar plugin - http://wordpress.org/extend/plugins/tweetily-tweet-wordpress-posts-automatically/

    Works well & able to exclude certain posts etc.

    Just tested it. Try giving that a go?

  6. KimJCastleberry
    Member
    Posted 2 years ago #

    I haven't tried that one Lianne, but definitely going to have a look at it. I'm inclined to want to use this one since it has a long long track record of being stable but won't help if I can't connect to twitter LOL
    Kim

  7. Ajay Matharu
    Member
    Posted 2 years ago #

    Read the faq it has the solution for this problem.

  8. AskKim
    Member
    Posted 2 years ago #

    I am the thread originator and have changed user IDs.

    Here's a quick followup

    Grabbed the most recent update that you just released (thank you)

    Now, however, instead of getting a redirect loop, after the authorization is clicked, it redirects to an api.twitter.com/login?redirect_after_login="%2Foath.... etc etc. that is a 404 "Sorry this page doesn't exist" error message.

    So I went to the instructions in the FAQ.

    I enabled logging, and clicked save.

    Then, intent to demonstrate the issue, I tried again, and suddenly it worked.

    I have no clue why that would have played a role but it did. (I've since turned off logging).

    Thanks Ajay,
    Kim

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic