Support » Plugin: NextScripts: Social Networks Auto-Poster » Twitter Posts not Posting Images

Viewing 11 replies - 1 through 11 (of 11 total)
  • Bump

    Anyone have a solution? IIRC, SNAP had a few updates very recently?

    Plugin Author NextScripts

    (@nextscripts)

    That doesn’t tell me anything though, I’ve tried all of those things. I even reset my twitter API and put in all the new codes and nothing.

    I guess I’ll go troubleshoot other plugins and see if there’s a conflict… I just hoped it was something with an update on your end.

    Plugin Author NextScripts

    (@nextscripts)

    Are you getting any errors? Please check your Log/History tab and let me know what do you have there.

    If your image is correctly set, Twitter should pick it up.

    Yeah, I didn’t know that existed! I got this error:

    [2014-11-24 22:23:44] – [Error] [Twitter – Niche Gamer] – Could not get image (http://www.nichegamer.net/media/2014/11/total-war-attila-11-24-14-1-1024×576.jpg), will post without it – Error: | PostID: 31527

    I have hotlink protection but I have the proper exceptions for my site and my image database..

    Plugin Author NextScripts

    (@nextscripts)

    Try to turn your protection off and make a post.

    I removed it and even waited a bit to make sure it took, the hotlink protection is off but I still get the same error 🙁

    Racter

    (@racter)

    I have the same problem. How do you solve it?

    Racter

    (@racter)

    [Error] [Twitter – Twitter] – Could not get image (http://ltrips.ru/wp-content/uploads/DSCN0279-dhankar_thumb-800×533.jpg), will post without it – Error: | PostID: 2792

    ps
    The hotlink protection is off!

    Plugin Author NextScripts

    (@nextscripts)

    ok. Let’s forget about SNAP plugin for a second.

    Let’s do a very quick test.

    create a file imgtest.php in the same folder as your WordPress files.

    Put this 3 rows of code in the file:

    <?php 
    
    require('wp-blog-header.php');
    
    $resp = wp_remote_get('http://ltrips.ru/wp-content/uploads/DSCN0279-dhankar_thumb-800x533.jpg'); 
    
    echo "<pre>".print_r($resp, true)."</pre>";          
    
    ?>

    Open it from your browser. Correct result should look like this: http://www.nextscripts.com/imgtest.php

    if you get an empty result or any errors, please work with your hosting provider, server admin or WordPress admin to resolve it.

    As soon as it fixed SNAP will start working as well.

    Racter

    (@racter)

    Yeeeesss!!!

    I had:

    127.0.0.1 localhost ltrips.ru

    in my etc/hosts file.

    I changed it:

    127.0.0.1 localhost

    I hope it is correct. 🙂

    Now it is working good!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Twitter Posts not Posting Images’ is closed to new replies.