Support » Plugin: Jetpack by WordPress.com » Twitter Oficial Button has Problems

  • Resolved Tomé Mendes

    (@ridfick)


    Hi there,

    After updating Jetpack and all the modules, the Official Twitter Button is having problems.

    After loading a Post the Twitter button don’t load, and in spite of this, a torrent file is downloaded with name “widgets-tweet_button.html”

    Only the classic ‘un-official’ buttons don’t have this action script.

    Does someone else have this issue?

    http://wordpress.org/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 17 total)
  • Same here, not sure if it’s caused by twitter button or something worse. Why should twitter use a torrent file?

    I confirm that it’s a jetpack issue, when disabled, the problem disappears.

    I think that this problem is caused by the share on twitter code, not by the plugin itself…

    I think that is a twitter problem too …

    If you request directly to twitter for the tweet_button widget,
    randomly, twitter answer us with a downloadable torrent url (this torrent is the twitter code)

    Request: curl -I -k http://platform.twitter.com/widgets/tweet_button.html

    This is the KO response:
    HTTP/1.1 200 OK
    Accept-Ranges: bytes
    Content-Disposition: attachment; filename=widgets/tweet_button.html.torrent;
    Content-Type: application/x-bittorrent
    Date: Sun, 22 Sep 2013 10:40:40 GMT
    Last-Modified: Sat, 21 Sep 2013 18:13:07 GMT
    P3P: CP=”CAO DSP LAW CURa ADMa DEVa TAIa PSAa PSDa IVAa IVDa OUR BUS IND UNI COM NAV INT”
    Server: ECS (mad/4388)
    X-Cache: HIT
    Content-Length: 301

    This is the OK reponse:
    HTTP/1.1 200 OK
    Cache-Control: no-cache
    Last-Modified: Thu, 19 Sep 2013 23:54:42 GMT
    ETag: “86e25ce34214e039e32bd33c7aaeefa6”
    Content-Type: text/html; charset=utf-8
    Date: Sun, 22 Sep 2013 10:28:27 GMT
    Connection: keep-alive
    P3P: CP=”CAO DSP LAW CURa ADMa DEVa TAIa PSAa PSDa IVAa IVDa OUR BUS IND UNI COM NAV INT”

    Yes, it’s a Twitter problem.

    If you use Jetpack with the Classic Buttons, this problem don’t happen.

    Hope they fix it soon…

    Hello,

    No, it’s not a twitter problem (otherwise it would affect a lot of website that use twitter button).

    It’s a problem on your machine.

    Here is the result on a “clean” server :
    HTTP/1.0 200 OK
    Cache-Control: no-cache
    Last-Modified: Thu, 19 Sep 2013 23:54:42 GMT
    ETag: “86e25ce34214e039e32bd33c7aaeefa6”
    Content-Type: text/html; charset=utf-8
    Date: Sun, 22 Sep 2013 18:54:06 GMT
    Connection: close
    P3P: CP=”CAO DSP LAW CURa ADMa DEVa TAIa PSAa PSDa IVAa IVDa OUR BUS IND UNI COM NAV INT”

    Hello,
    JC91, the both request that I post, was from the same machine … I see the bad request on many sites and many people is reporting this behavior

    for example

    http://www.commentcamarche.net/news/5863187-twitter-victime-d-un-bug-widgets-tweet-button-html-torrent

    Christina Beatriz Gaarslev

    (@christina-beatriz-gaarslev)

    Hello,
    I have the same problem, it begun yesterday after subscribing to a blog. Every time I access my blog as Admin. the message “Do you want to open or save widgets_tweet_button.html.torrent (301 bytes) from platform.twitter.com” appears, and here comes the worst part, if I try to view the blog all admin. tools disappear, I can’t even log-out (personally I haven’t even got a twitter account).
    How can it be deactivated?

    This problem appears if you use the iframe code for the “tweet this post” button. If you change the code to:

    <script src="http://platform.twitter.com/widgets.js" type="text/javascript"></script>
       <a href="http://twitter.com/share" class="twitter-share-button"
          data-url="<?php the_permalink(); ?>"
          data-via="MY_TWITTER_ACCOUNT"
          data-text="<?php the_title(); ?>"
          data-count="horizontal">Tweet</a>

    the problem disappears: in my case, my blog does not show the annoying torrent download anymore after that change.

    Hope it helps.

    Christina Beatriz Gaarslev

    (@christina-beatriz-gaarslev)

    Thanks so much for trying to help me, but this problem is that the twitter button is not activated, (I haven’t even got a twitter account), so where do I type the code?

    Hi,

    You don’t need a Twitter account to have a Twitter button. In a lot of wordpress themes, these buttons are included in their code so… Maybe the code of the button is there but you cannot see it…

    Anyway, if your theme has the option of insert the button and you have deselected that option, maybe you have found an error of the theme (?)

    Christina Beatriz Gaarslev

    (@christina-beatriz-gaarslev)

    Thanks so much, nothing like talking to experts. In settings the button was hidden in a “more” pick list, I moved it to the section of available buttons, and apparently the message has disappeared – or at least I hope so, I have entered twice, and it didn’t show up.

    I can confirm the problem. I have the problem on one machine with several virtual hosts.

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Is anyone still experiencing this problem? If so, let me know!

    Would it work better if this topic was closed and people posted new topics if they still have this problem?

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Twitter Oficial Button has Problems’ is closed to new replies.