Support » Plugin: Social Share, Social Login and Social Comments Plugin - Super Socializer » Twitter social login not working with “loggedout” param in the URL

  • Resolved sproutchris

    (@sproutchris)


    After logging out and trying to login again with Twitter, it successfully logs me in, but it doesn’t redirect me back to the site; it only gives me the login screen without the social login icons. The user should have no idea that they’re logged in.

    The only time when it does this seems to be when “loggedout=true” is in the URL string. It seems to be creating a conflict with the iThemes Security plugin “Hide Backend” feature that changes the WordPress login URL. When this feature is disabled, this issue does not occur.

    • This topic was modified 3 years ago by sproutchris. Reason: Discovered the culprit was not changing the WordPress login URL like originally thought
    • This topic was modified 3 years ago by sproutchris.
    • This topic was modified 3 years ago by sproutchris. Reason: It does in fact only happen when the "Hide Backend" feature of iThemes Security plugin is enabled

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter sproutchris

    (@sproutchris)

    If it helps at all, this may be related to the issue solved in releases 7.8.17/18 in which some issue occurred with the LiveJournal login when “?loggedout=true” was in the query string (according to the Changelog in the plugin readme file).

    Thread Starter sproutchris

    (@sproutchris)

    Looks like this issue is also occurring when using Facebook to login, and who knows how many others.

    Plugin Contributor Heateor Support

    (@heateor)

    It seems to be creating a conflict with the iThemes Security plugin “Hide Backend” feature that changes the WordPress login URL.

    We can login from the link you mentioned above. See screencast https://www.dropbox.com/s/dw7rp8wk9e5a3oq/%20realestate.columbian.com.mp4?dl=0

    Thread Starter sproutchris

    (@sproutchris)

    In your screencast, you did not log out and try and log back in again. This is the scenario in which loggedout=true is in the URL. It will log in just fine when you initially log in, but when you log out and try to log back in again, it doesn’t redirect you to homepage.

    Thread Starter sproutchris

    (@sproutchris)

    See screencast: https://www.dropbox.com/s/60ja80fs5uus864/col-homes-login-issue-2018-04-25-09-02-56.webm?dl=0

    Notice:
    – the loggedout URL parameter after going back to the login screen after logging out (starting at :09)
    – After I try logging back in after logging out, it autofills the username of the account I’ve just logged in using Twitter.
    – After I clicked on the site logo to return to the home page, I click the user icon to show that I am in fact logged in; it just didn’t return me to the front page.

    Plugin Contributor Heateor Support

    (@heateor)

    Okay. It seems because of the itsec-hb-token=userlogin added to the url. Try replacing existing wp-content/plugins/super-socializer/super_socializer.php at your website server with the one at following link:
    https://gist.github.com/Heateor/3b5a7ccf6aa8db04555b13976cd01231

    Thread Starter sproutchris

    (@sproutchris)

    Thanks; I replaced the code in super_socializer.php with version you provided and the behavior is unfortunately the same.

    Plugin Contributor Heateor Support

    (@heateor)

    If you drop an email at support[at]heateor[dot]com, we might be able to assess the situation.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Twitter social login not working with “loggedout” param in the URL’ is closed to new replies.