WordPress.org

Forums

Super Socializer
[resolved] Twitter login not working (21 posts)

  1. zandercent
    Member
    Posted 2 years ago #

    Hi I've set up the twitter login, as per instructions, but it doesn;t seem to be working

    when people click sign in with twitter the twitter authorisation screen pops up. you click accept, and get redirected to

    http://myhomepage.com/?theChampEmail=1&par=1347607078

    I've tried with and without the 'llow this application to be used to Sign in with Twitter' option checked

    Any thoughts?

    https://wordpress.org/plugins/super-socializer/

  2. Rajat Varlani
    Member
    Plugin Author

    Posted 2 years ago #

    There seems something wrong with your website.
    Can you provide me your website url so that I can look into the issue?

  3. zandercent
    Member
    Posted 2 years ago #

    is there a way to DM you?

  4. Rajat Varlani
    Member
    Plugin Author

    Posted 2 years ago #

    Yes. Email me at lordofthechamps@gmail.com

  5. airsid
    Member
    Posted 2 years ago #

    Hi,
    First of all thanks for your great pluugin, works perfect with Facebook.

    But with Twitter I've got the same issue than zandercent.
    Here is a link to my site.
    Coould you help please ?

  6. airsid
    Member
    Posted 2 years ago #

    Hi,
    Thanks for your gret pugin.

    I've got the same issue.
    Here is a link to my site, can you please help ?

  7. Rajat Varlani
    Member
    Plugin Author

    Posted 2 years ago #

    Hi airsid,
    I am looking into this and get back to you.

  8. airsid
    Member
    Posted 2 years ago #

    Hi,
    Also Facebook login/register window don't show anymore, I can't click on it.
    Please help.

  9. Rajat Varlani
    Member
    Plugin Author

    Posted 2 years ago #

    @airsid: For Twitter login issue:
    Can you change the text saved in option - 'Error message for 'Email required' popup' so that it doesn't have any single quote character('). Currently you have saved - "L'adresse mail indiquée est déjà utilisée ou invalide". Remove single quote from it.
    I am looking into Facebook login issue.

  10. airsid
    Member
    Posted 2 years ago #

    Hi,
    Thanks i've withdraw the single quote character(') and now Twitter is working great !

    ...just still Facebook issue...

  11. Rajat Varlani
    Member
    Plugin Author

    Posted 2 years ago #

    For Facebook issue, follow the steps mentioned below:
    1. Delete "wp-content/plugins/super-socializer/uninstall.php" from your WordPress installation folder.
    2. Navigate to "Plugins" page in your website admin panel and delete the plugin from there. (Do not worry you will not loose your configuration settings)
    3. Download the plugin and install it at your website.

  12. airsid
    Member
    Posted 2 years ago #

    Hi,
    I've followed your instructions step by step, but
    For registration:
    Under Firefox, I have to delete each time the historical of the navigator to see the Facebook logo and be able to click on it. Under Safari, Facebook is working, don't need to clean the historical.
    For login:
    Under Firefox and Safari, the Facebook logo is shown but I still can't click on it.

  13. Rajat Varlani
    Member
    Plugin Author

    Posted 2 years ago #

    Seems, some other plugin is blocking the request for login to Facebook. Are you using any such plugin (like - AVH or something)? Try disabling it to check if it is causing the issue.

  14. Rajat Varlani
    Member
    Plugin Author

    Posted 2 years ago #

    I have released a maintenance version to fix this bug. Please update your plugins to version 2.5.2
    Let me know if issue persists after updating the plugin.

  15. airsid
    Member
    Posted 2 years ago #

    Hi,
    Thanks a lot, great support. You were right, "AG Custom" plugin was blocking the request for login to Facebook. After deactivating it's working.

    But under Firefox, when go on the webiste, if I click on "register" in the toolbar facebook logo appears and works. But if I go first to "login" page then to "register" page, the facebook logo doesn't appear anymore. I have to go back to the site homepage (and then click on "register" in the toolbar) or to clear historical of the register page to see the facebook logo again on the page.

  16. Rajat Varlani
    Member
    Plugin Author

    Posted 2 years ago #

    Open "wp-content/plugins/super-socializer/css/front.css" in code editor and change the following CSS at line number 282

    .theChampFacebookButton {
    	background-position: -0px -0px;
    	width: 32px;
    	height: 32px;
    	display: none;
    }

    to following:

    .theChampFacebookButton {
    	background-position: -0px -0px;
    	width: 32px;
    	height: 32px;
    	display: block;
    }

    Save the file.

  17. airsid
    Member
    Posted 2 years ago #

    Works perfectly ! Thanks.
    Should I copy the front.css file in the child theme under
    wp-content/themes/child-theme/super-socializer/css/front.css ?

  18. Rajat Varlani
    Member
    Plugin Author

    Posted 2 years ago #

    I could not understand what is the use of copying this file in your child theme folder.

  19. airsid
    Member
    Posted 2 years ago #

    Just to be sure it won't be deleted at the next update...no ?

  20. Rajat Varlani
    Member
    Plugin Author

    Posted 2 years ago #

    Just copying it in the child theme folder won't work because plugin will not check for the CSS in child theme folder. It checks it in "wp-content/plugins/super-socializer/css" folder.
    Instead you can copy "front.css" in a separate place and use it to make the changes againg in "wp-content/plugins/super-socializer/css/front.css" file, in case the CSS fix get deleted after updating the plugin.

  21. airsid
    Member
    Posted 2 years ago #

    OK i'll do that. Thanks for your quick support ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags