Support » Plugin: JM Twitter Cards » Twitter Image Not Loading

  • Hello there,

    Thanks for having this plugin.. Really helps out. I am however having a bit of trouble getting the image to show up in twitter or even in the validator. It says my card is fine all green, but no image. The page source shows the image is there too. I also have the proper information in the robots.txt file.

    I just cannot get that damn image to show up or get a straight answer what the size of the image should be that I use. Even the temp image I have in there now is 148×148 and gets cut off.. Not sure what to do at this point.. Please advise.. thanks

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author jmau

    (@jmlapam)

    Hi,

    edit: hum, seems Twitter has changed (again) its rules. Will check that when I got the time and come back to you later.

    • This reply was modified 7 months, 4 weeks ago by jmau.
    Thread Starter saxamo

    (@saxamo)

    I have noticed a few things about this plugin.

    If you choose not to show pages then it turns off the option for twitter on posts.

    What is weird and not perfect is that slack and whatsapp are showing different things after a period of time. So whatsapp shows what it should but no image and just text. Slack shows what it should minus an image but does include the favicon which is really a nice item.

    I still even though the card gets validated cannot show the images that I set.

    I do not have SEO plugin installed so I am relying completely on this plugin to show what it is supposed to do.

    This plugin is so perfect if you could work out the small details.

    fix the item where checking off what not to show shows the proper item. checking page turns off post.

    then this setting – Open Graph/SEO what does it do if you don’t have an SEO plugin installed..

    I just want the twitter card to work. I don’t want a full heavy thing like Yoast installed.. I just want the little things I choose to work.. This plugin has so much potential and is exactly what I am probably a lot of people need to just get that functionality. Has this ever been tested behind cloudflare. It seems it takes about 2 hours even after a cache flush to see results.. in slack and whatsapp.. If I see it there then I check twitter..

    Now in twitter I am not sure if it is doing what it is suppose to and I have deactivated a few plugins so that there is no issues..

    I would really like this to work.. I know you are busy and cannot start to thank you for the time you have put in.. If you would like access to the site please contact me and I will give it to you.. maybe seeing what is going on in the backend might help.

    Thanks again..

    Plugin Author jmau

    (@jmlapam)

    If you choose not to show pages then it turns off the option for twitter on posts.

    Can’t reproduce this bug. The post type option is for selecting all post types where you want the metabox or the Gutenberg Sidebar to appear.

    So whatsapp shows what it should but no image and just text. Slack shows what it should minus an image but does include the favicon which is really a nice item

    The plugin does not handle Whatsapp and Slack, only Twitter cards markup.

    – Open Graph/SEO, what does it do

    It adds meta type “og” insted of classic meta in the head section

    Can’t reproduce the bugs you mentioned. Did not find what can cause your image issue in your hacker’s website. I’ll send an update but I’m afraid it will only be a security release with vendors updates

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Twitter Image Not Loading’ is closed to new replies.