Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Twitter Image Blocked

  • Resolved Andrew Arthur Dawson

    (@andrewarthurdawson)


    I am unable to get any image over to Twitter anymore. Even my own personal blog site picture, which is in every one of my blog’s, is unable to render. The following is the message I get…

    INFO: Page fetched successfully
    INFO: 24 metatags were found
    INFO: twitter:card = summary_large_image tag found
    INFO: Card loaded successfully
    WARN: The image URL https://secureservercdn.net/###################-content/uploads/2014/05/For-New-Blog2-1024×286.jpg?w=640 specified by the ‘twitter:image’ metatag may be restricted by the site’s robots.txt file, which will prevent Twitter from fetching it.

    I blocked out part of the IP address for security purposes with the #’s. But you can use any of my my recent postings on my blog and see what’s happening.

    Use the Twitter testing tool with this link for exmaple – https://thetwelfthstep.com/2021/01/12/thought-for-the-day-585/

    And you’ll get the image is blocked like all images are now blocked…by robots. I presently don’t have any issues on Facebook. There are no other plugins running other than Akismet and Relevanssi and Classic Editor, none of which deal with how metadata is handled.

    Please help.

    Sincerely,
    Andrew Arthur Dawson

    The page I need help with: [log in to see the link]

Viewing 15 replies - 16 through 30 (of 33 total)
  • Plugin Contributor Dan

    (@drawmyface)

    The quotes in your comment above are ‘curly quotes’, but it looks like the forum may convert them to that if you don’t use the ‘code’ format.

    You can’t use FileZilla to access your database, you’ll need to use phpMyAdmin or another MySQL tool, which should be included in your hosting control panel. You need to view your site’s database, then go to the wp_options table and search for the jetpack_publicize_options option.

    Thread Starter Andrew Arthur Dawson

    (@andrewarthurdawson)

    @drawmyface the only access I have to ever looking at my database has been going into FileZilla. I’ve made some minor changes in there before using it. That’s all Godaddy allows for me. So if I can’t make this change there like I have when I’ve deleted the jetpack folders there due to an update failure them I don’t have any other solution. This is option I’ve always used to accessing my database and the only one I have. I have managed wordless and my options are limited but FileZilla is indeed what I’ve always used to access my database.

    Plugin Contributor Dan

    (@drawmyface)

    The filesystem, which you can access via FileZilla and manage files and folders, is a completely separate thing from your database, which is where your post content and other site data is stored.

    You should be able to log into that via GoDaddy’s cpanel, e.g. https://uk.godaddy.com/help/open-phpmyadmin-24573

    Thread Starter Andrew Arthur Dawson

    (@andrewarthurdawson)

    @drawmyface yup, nope. I am not on their cpanal sadly. I have very little options with my managed WordPress with godaddy. Been down this path before the very first time I had issues with jetpack. If my jetpack update fails I use FileZilla to delete the appropriate jetpack folders and such and of course I can make minor changes there but my version of WordPress does not give me access to change the database core files. If this is a core file change then no I don’t have access and I guess I’m screwed and don’t know how to fix this. I purposely have been on this version of godaddy for six years because I don’t understand all this technical stuff with WordPress and wanted godaddy to handle any WordPress updates and core database file changes. The next upgrade to my platform is the one you are speaking of and I absolutely do not want to migrate to that because it puts more control in my hands and believe me I have screwed my whole WordPress up just in going into FileZilla before so giving me more power to manage stuff isn’t a good thing. So if I can’t access that file in my normal jetpack accessing option when I have to go into FileZilla to delete my jetpack folders then I have no solution?

    Plugin Contributor Dan

    (@drawmyface)

    Ok, another option is to install a plugin such as https://wordpress.org/plugins/wp-phpmyadmin-extension/ which lets you browse your database from within your WordPress dashboard.

    Note that this is only to check the value of the jetpack_publicize_options option in your database, to determine whether the code snippet is working correctly. You shouldn’t actually edit anything in the database directly.

    Thread Starter Andrew Arthur Dawson

    (@andrewarthurdawson)

    @drawmyface Are there any risks to installing that plugin that could mess up my operations. I ask this because as I said I’m not technical with WordPress and godaddy support isn’t helpful more than not to help fix anything. If it is simply me downloading a plug-in and it only is me pointing and clicking to see something and is read only where I can’t screw something up then great? Just let me work the exact steps and any risks please ok Dan?

    Thread Starter Andrew Arthur Dawson

    (@andrewarthurdawson)

    @drawmyface there are definitely some concerns with that plug-in when I went to the page to read about it? A few users lost their database due to installing it and others said there was a malicious file put on their system that remained after using it and deleting it. I’m feeling pretty overwhelmed about this now. Man I wish this was simple fix. Code snippets should have changed this easily. Would a jetpack software update fix this?

    Plugin Contributor Dan

    (@drawmyface)

    There’s always some risk when working directly with the database. If you’re not comfortable with that, it may be best to avoid it.

    Would a jetpack software update fix this?

    I would recommend updating to the latest version of Jetpack, but no, I don’t think it will make a difference as this filter was in place prior to the version of Jetpack you’re currently using.

    Can you try once more activating the Code Snippets plugin, and creating a new snippet, then copy and paste this exact code:

    add_filter( 'jetpack_publicize_options', function( $option ) {
    $option['attach_media'] = false;
    return $option;
    } );

    It should look like this:

    https://d.pr/i/BsCQMi

    Activate that to run everywhere, then test Publicize again. If that doesn’t work, then I think there must be something else conflicting somewhere.

    Thread Starter Andrew Arthur Dawson

    (@andrewarthurdawson)

    @drawmyface yes indeed I think it would be too much of a risk to download that plug-in to browse the database given my limited expertise then. I will do as you asked above. I will delete the other snippet that currently is turned off but still there. Then add that code and activate again. I need to ask though, can doing that a second time or third time screw the database up and I don’t see the difference between the code in the window above or the code in the link you put below it? Is there a difference?

    Plugin Contributor Dan

    (@drawmyface)

    This won’t damage the database, no.

    There should be no difference in the code, this is just to confirm that there’s no issue resulting from a previous copy/paste error. Let me know how it goes.

    Thread Starter Andrew Arthur Dawson

    (@andrewarthurdawson)

    @drawmyface just needed to ask as I don’t want to hose my database up. So I deleted the existing code snippet I put in already and deactivated snippets. In a bit I will go back and reactivate snippets and create a title for it called Twitter image display. I will click the link you gave me in the previous response and copy and paste that code in. Save it with the activate everywhere option and then run it? And once it’s activated do I leave it activated or do I then delete it as soon as I activate it? I guess what I mean is does it need to remain active? Note – I won’t be posting my blog until just after midnight tonight so I won’t be able to test it till then. And just to verify it’s all single quotes in the snippet and the word false is all in lower case. In other words the code as you have in that link is exactly as it needs to be in snippets right?

    Plugin Contributor Dan

    (@drawmyface)

    I will click the link you gave me in the previous response and copy and paste that code in.

    You can copy the code directly from my post above. The link is just a screenshot that shows what it should look like in the Code Snippets editor. If the code is correct it will be colour coded like in the screenshot.

    Save it with the activate everywhere option and then run it?

    Yes.

    And once it’s activated do I leave it activated or do I then delete it as soon as I activate it? I guess what I mean is does it need to remain active?

    After activating it, it will run immediately so you don’t need to leave it activated (although it won’t hurt anything if you do).

    Note – I won’t be posting my blog until just after midnight tonight so I won’t be able to test it till then.

    No problem.

    And just to verify it’s all single quotes in the snippet and the word false is all in lower case. In other words the code as you have in that link is exactly as it needs to be in snippets right?

    Yes, that’s correct.

    Thread Starter Andrew Arthur Dawson

    (@andrewarthurdawson)

    @drawmyface curious, would turning off jetpack Twitter publicize and then re-adding it back be also a good thing to try? And if so, would doing that remove all the Twitter field for my future posts set up where I already have that block filled for what goes over to Twitter with the 256 characters? In other words would I lose that text turning the publicize off and back on?

    Thread Starter Andrew Arthur Dawson

    (@andrewarthurdawson)

    @drawmyface I answered my own question on the last one at least with the losing any data. I disconnected the Twitter option then reconnected it just to have one more test thrown in this whole thing. I did not lose any of the text in the 256 character boxes so I’m guessing this info is stored on your end thankfully.

    Anyway, I added the code snippet, it presently is active. I did match it directly to the link you provided with the color and it indeed is 100% a match.

    If this works, awesome, I pray it does and I will let you know after I post tonight just after midnight. If it doesn’t work, I have no idea why. And sadly, I don’t feel comfortable enough to muck around with database plugins or ways around my Managed WordPress in GoDaddy’s limitations. The only other thing I will be able to try is when I update to the latest version of Jetpack from my present one, which I was holding off on due to some resource issues that GoDaddy had been having for a good while and the last time I had tried a Jetpack update it had failed twice and I had to reinstall a backup to get back up and running.

    In the meantime, before I post this tonight, I just wanted to give you the entire rundown of how this transpired to see if you had any other ideas of why this might be happening.

    1. Twitter image was constantly being blocked.
    2. I placed that code snippet in initially with that set to ‘true’, activated it. Still had the issue with the image going through.
    3. Discovered it was related to “CDN” being turned on in my Managed WordPress settings since last summer. I turned it off.
    4. The images started displaying again, but showing them separately from the text rather than the picture being a link itself. The twitter test card showed it displaying correctly when I put it in there, but each publicize kept the image separately.
    5. I continued to delete each auto post from Jetpack and then re post the link so it would look right.
    6. I then took the initial code from what I used before and changed the one value from ‘true’ to ‘false’. Activated it and nothing changed.
    7. I deleted it, deactivated code snippets. Then reactivated code snippets and have just re-added it using what you provided exactly and matched it once saved and activated to the link you provided. It presently remains in an active state with the code snippets slide bar for it set to on.
    8. I disconnected Twitter on WordPress.com’s options for publicize and reconnected it.
    9. Presently, I will be testing this tonight again and praying it works. If it doesn’t, I have no idea what else to try and maybe you might?

    (BTW, I once was a software tester for many years. I’m more of a front end guy then a back end programmer type of guy and tend to break things more than fix things. lol)

    Thread Starter Andrew Arthur Dawson

    (@andrewarthurdawson)

    @drawmyface Well interestingly enough, I can finally report some great news. Tonight’s posting came through as it should. I did a few extra steps and am unsure if any of this helped but I did as mentioned in my last posting above, disconnect from Twitter Publicize on the Jetpack Publicize page and then reconnect. I also made sure to delete all snippets, deactivate code snippets, then reactivate, and copy and paste exactly as you had placed. The last step I did was to clear the cache in all of my browsers before I posted tonight. So, there you have it. I did turn off the snippet that you gave me and then deactivated code snippets after I posted tonight. I’d like to have one more test for my next posting in 24 hours to make sure it still works and if it does, then we can close this thread ok?

Viewing 15 replies - 16 through 30 (of 33 total)
  • The topic ‘Twitter Image Blocked’ is closed to new replies.