Support » Plugin: SharePress » Twitter Error 215 Bad Authentication data

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor joeyblake

    (@joeyblake)

    Hi Mustafa,

    You probably need to make sure you have all of the correct permissions. The step by step apps setup instructions are here. If that doesn’t work, hit us up on the support widget on the site.

    http://getsharepress.com/setup

    Hi Joey,

    2 months ago, I uninstalled and reinstalled Sharepress and that solved the problem.

    But, yesterday I moved my website to another server, and I started getting exactly the same error! :((

    What I tried so far is:

    • Uninstalling and reinstalling Sharepress;
    • Regenerating the keys
    • Creating a new Twitter app

    Still the same problem 🙁

    Do you have any recommendations?

    Plugin Contributor joeyblake

    (@joeyblake)

    Could be DNS? Did your ip change when you switched servers?

    Plugin Contributor joeyblake

    (@joeyblake)

    You’ll also want to make sure that you have curl installed on the new server.

    Hi joeyblake,

    thanks for the answers.

    I confirmed that curl is installed. By the way, it can post on Facebook. The problem is only with Twitter.

    Yes, the IP changed. Should I do anything for that?

    I debugged it. it seems the confidential data is coming correctly till Sharepress_WordPressOAuth::post(). The variables in self::build_http_query($params) are:

    oauth_consumer_key=***
    oauth_nonce=***
    oauth_signature=***
    oauth_signature_method=HMAC-SHA1
    oauth_timestamp=1412063309
    oauth_token=***
    oauth_version=1.0
    status=test%20tweet
    wrap_links=1

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Twitter Error 215 Bad Authentication data’ is closed to new replies.