WordPress.org

Forums

Ryu
[resolved] Twitter embeds not displaying properly (11 posts)

  1. johnbierly
    Member
    Posted 2 years ago #

    Ryu is flippin' ridiculous. And I mean that in the best possible way. Amazing. Beautiful. Best theme ever. Outrageous. It's OUTRAGEOUS.

    Only issue I see is that Twitter embeds are only showing up as text in the blockquote style. I've tried it on every browser, on a PC, on a Mac, on my phone, on my tablet:

    http://www.johnbierly.com/6709

    Do Twitter embeds simply not display that largely?

  2. Takashi Irie
    Theme Wrangler at Automattic
    Posted 2 years ago #

    Hi John,

    I'm assuming you are simply copy the URL for a Tweet and paste it on a single line in your post, correct?

    Since an embedded tweet displays as expected for me, I suspect it might not be the theme's issue.

    Could you switch Ryu to something else like Twenty Twelve temporarily to see if the tweet displays correctly?

  3. johnbierly
    Member
    Posted 2 years ago #

    Hi, Takashi!

    Here it is on Twenty Twelve, using the embed code from the Tweet:

    http://www.johnbierly.com/wp-content/uploads/2012.jpg

    That's how it displays on all the other themes I've tried.

    And this is how it displays on Ryu:

    http://www.johnbierly.com/wp-content/uploads/ryu.jpg

    Thanks again for your time!

    Oh, here's what the Twitter code looks like:

    <blockquote class="twitter-tweet">Officially like to welcome <a href="https://twitter.com/search/%23PeterDinklage">#PeterDinklage</a> from <a href="https://twitter.com/search/%23GameOfThrones">#GameOfThrones</a> to <a href="https://twitter.com/search/%23XMEN">#XMEN</a> <a href="https://twitter.com/search/%23DaysofFuturePast">#DaysofFuturePast</a> Very very excited!
    
    — Bryan Singer (@BryanSinger) <a href="https://twitter.com/BryanSinger/status/301886258572046338">February 14, 2013</a></blockquote>
  4. johnbierly
    Member
    Posted 2 years ago #

    (Also, HUGE thanks to everyone involved in making this spectacular theme. I'm loving it and getting great comments from readers about it.)

  5. Takashi Irie
    Theme Wrangler at Automattic
    Posted 2 years ago #

    Hi John,

    Thanks for testing. That's weird because I don't have problem to embed a tweet. I'd recommend to use just the url of the tweet as advised by Twitter here (See "Embedding from WordPress and other CMSs" section.) This is because the link to their js in the embed code will be stripped out if you switch the editor from text to visual (or vise versa).

    Could you try to paste the url of the tweet on a single line in text mode and see if the issue goes away?

    https://twitter.com/BryanSinger/status/301886258572046338

  6. johnbierly
    Member
    Posted 2 years ago #

    That works perfectly, Takashi! Thank you again for your time! In the future I know not to over-complicate it and just paste in the URL of the Tweet. Deepest thanks.

  7. Takashi Irie
    Theme Wrangler at Automattic
    Posted 2 years ago #

    You're welcome. I'm glad you like the theme :)

  8. Crespo
    Member
    Posted 1 year ago #

    Hello,

    I see that in CMS like WordPress self-hosted.

    As you can see in two different types of embed tweets and doen't work when i only paste URL, if p paste this embed code the tweet appears:

    <p>Enroll in a health plan today and be covered on February 1st: http://t.co/Y6LKz1aL43 pic.twitter.com/4GdsoqRxST</p>— Barack Obama (@BarackObama) enero 15, 2014

    <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>

    But if i paste this status link doesn't work:

    https://twitter.com/BarackObama/status/423575812311240704

    Why don't work with pasted url in text version?

    You can check in one of my websites, and old post:
    http://www.maduradas.com/oscar-de-leon-se-manifiesta-sobre-la-inseguridad-en-venezuela-tuits/

    A post from yesterday:
    http://www.maduradas.com/bocaranda-es-insostenible-para-empresas-polar-producir-les-deben-400-millones/

    Hope you can help me, i'm going grazy with this.

    Thanks!!

  9. Hi MnLGmz - you might not have realized it, but this forum is specifically for issues with the Ryu theme.

    Since you're not using Ryu, and this 8-month-old post is already marked as resolved, would you kindly start your own thread in one of the general forums, such as Troubleshooting:

    http://wordpress.org/support/forum/how-to-and-troubleshooting

    Thanks!

  10. lstelie
    Member
    Posted 1 year ago #

    Hello,

    From my own expérience it's not a Ryu related issue but a browser related issue.

    With latest Ruy and WP version on a self hosted WP

    • On my Mac : no problems with Chrome and Safari
    • On my office PC: direct link doesn't work in Chrome
      full twitter embed code works on Firefox doesn't work entierely with Chrome (picture if any not diaplayed, text only display
  11. MnLGmz - the recent Twitter embedding bug is likely due to Twitter discontinuing its old API about a week ago. You can follow this Core ticket, which should fix the issue in WordPress 3.8.1:

    https://core.trac.wordpress.org/ticket/26844

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.