WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Twitter Embed URL Not Working (3 posts)

  1. lccom08
    Member
    Posted 4 months ago #

    In WP, I used to be able to simply put in the Twitter URL in my blog posts and boom, the link got embedded properly automatically. Here's an example of such a URL:
    https://twitter.com/rozfashionista/status/376803834024452096

    The same behavior is supposed to happen when you do:
    [embed]https://twitter.com/rozfashionista/status/376803834024452096[/embed]
    (source http://codex.wordpress.org/Embeds)

    The only way to get the embeds to work again is to go to each Twitter URL, find and copy the embed code, and add it in under the text or "html" view.

    I cannot go through and edit all these twitter links to get them to be embedded again. There are just too many.

    The source code shows me the p tags automatically get wrapped now:
    <p>https://twitter.com/rozfashionista/status/376803834024452096</p>

    I've tried each of the following independently:

    1. Adding code to the bottom of my functions.php file -

    remove_filter( 'the_content', 'wpautop' );
    remove_filter( 'the_excerpt', 'wpautop' );

    2. wpautop-control plugin

    3. Raw HTML plugin
    [raw]https://twitter.com/rozfashionista/status/376803834024452096[/raw]
    [embed][raw]https://twitter.com/rozfashionista/status/376803834024452096[/raw][embed]
    [raw][embed]https://twitter.com/rozfashionista/status/376803834024452096[/embed][/raw]

    4. Deleting in visual mode and adding back into text mode.

    ==
    When I achieve getting the twitter link to display without the <p> tags, the link just sits there as plain text and doesn't get embedded.

    An example of the correct source code after being embedded is:

    <blockquote class="twitter-tweet" width="550"><p><a href="/web/20131007095739/https://twitter.com/jbecher">@jbecher</a> : &quot;looking at numbers of overlap customers, we see a huge upside here alone + expect huge uptake in <a href="/web/20131007095739/https://twitter.com/search?q=%23EmergingMarkets&src=hash">#EmergingMarkets</a>&quot; <a href="/web/20131007095739/https://twitter.com/search?q=%23OmniCommerce&src=hash">#OmniCommerce</a></p>
    <p>&mdash; Sven Denecken (@SDenecken) <a href="/web/20131007095739/https://twitter.com/SDenecken/statuses/364774739920687105">August 6, 2013</a></p></blockquote>

    Any help is much appreciated in advance!

  2. lccom08
    Member
    Posted 1 month ago #

    Hello, has anyone had any success with ironing out this issue?

  3. esmi
    Forum Moderator
    Posted 1 month ago #

    If you require assistance then, as per the Forum Welcome, please post your own topic instead of tagging onto someone else's topic.

    This 2 month old topic references a pretty old version of WordPress.

Topic Closed

This topic has been closed to new replies.

About this Topic