Support » Plugin: NextGEN Facebook » Twitter counter always = 0

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author JS Morisset

    (@jsmoriss)

    I’m on the road today. Ill check it tomorrow morning. Do you have an example URL?

    Btw this is usually a diff between the URL shared, and a “canonical” URL set by an seo package that would be different.

    Ill let you know what I see tomorrow morning.

    Thanks,

    JS.

    cruzgloriosa

    (@cruzgloriosa)

    Hi JS.

    Here an example URL: http://www.cruzgloriosa.org/kiko-doctorado-honoris-causa-lublin/

    Thanks for help.

    Plugin Author JS Morisset

    (@jsmoriss)

    Well, that’s a bit of a mystery… The button HTML looks good:

    <script type="text/javascript" id="twitter-script-header">ngfb_header_js("twitter-script-header","https://platform.twitter.com/widgets.js");</script>
    
    <!-- Twitter Button -->
    <!-- url = http://www.cruzgloriosa.org/kiko-doctorado-honoris-causa-lublin/ -->
    <div class="twitter-button" id="twitter-button twitter-button-post-2719">
    <a href="https://twitter.com/share" class="twitter-share-button" lang="es" data-url="http://goo.gl/R6Cvg" data-text="Doctor gracias a un Maestro perseguido, muerto y sepultado" data-via="" data-count="horizontal" data-size="medium" data-dnt="true">Tweet</a>
    </div>

    My guess is there’s something interfering with Twitter’s javascript… On the Social Sharing settings page, try setting the JavaScript location in the footer.

    Try switching the button to English, and see if that works — could be a bug in the Twitter javascript.

    BTW, somewhat unrelated, but you have two sets of Open Graph meta tags — you should really remove these:

    <!-- Wordbooker generated tags --><meta property="og:locale" content="en_US"/> <meta property="og:site_name" content="Camino Neocatecumenal - Material e información importante de una de las realidades eclesiales más importantes de los últimos tiempos dentro de la Iglesia Católica"/> <meta property="fb:admins" content="100005574093340"/> <meta property="og:type" content="article"/> <meta property="og:title" content="Doctor gracias a un Maestro perseguido, muerto y sepultado"/> <meta property="og:url" content="http://www.cruzgloriosa.org/kiko-doctorado-honoris-causa-lublin/"/> <meta property="og:image" content="http://www.cruzgloriosa.org/wp-content/plugins/wordbooker/includes/wordbooker_blank.jpg"/> <meta name="description" content="Me permito reescribir la historia... que me perdonen los prestigiosos medios.   El Camino Neocatecumenal recibió en la persona de su iniciador Kiko Argüello el doctorado honoris causa por la Universidad Juan Pablo II de Lublín el pasado 26 de junio.      Es ..."/> <meta property="og:description" content="Me permito reescribir la historia... que me perdonen los prestigiosos medios.   El Camino Neocatecumenal recibió en la persona de su iniciador Kiko Argüello el doctorado honoris causa por la Universidad Juan Pablo II de Lublín el pasado 26 de junio.      Es ..."/> <!-- End Wordbooker og tags -->

    js.

    Plugin Author JS Morisset

    (@jsmoriss)

    cruzgloriosa,

    Were you able to track down the problem?

    Thanks,

    js.

    cruzgloriosa

    (@cruzgloriosa)

    Hi, JS.

    I tried this but, not work.

    Thank you for tell me i have duplicated Open Graph meta tags, i use Wordbooker plugging for publish comments from Facebook into my web.

    I see configuration of worbooker and not appear option for Open Graph meta tags. Any idea for eliminate duplicate?

    Plugin Author JS Morisset

    (@jsmoriss)

    Look for an option in Wordbooker called “Disable in-line production of OpenGraph Tags”. You’ll want to check that option.

    Have you tried switching to English for the Twitter button?

    Did you try disabling other plugins?

    Does the Twitter counter stay at zero on all pages, or just one?

    js.

    cruzgloriosa

    (@cruzgloriosa)

    Hi JS,

    Thanks for Wordbooker indication, this part it’s ok.

    For Twitter, i switched to English and i disabled all pluggings, but not working… The counter is 0 in all Pages or Posts… If you can, look any pages or posts at http://www.cruzgloriosa.org i will let all plugging disabled any minutes…

    Plugin Author JS Morisset

    (@jsmoriss)

    I added an extra field to the Twitter sharing URL. Normally Twitter tracks counts using the data-url argument, but there’s another another (somewhat undocumented) argument called data-counturl, which we can use to track the “official” (aka long) URL for the webpage.

    If you download and install the latest DEV version from http://downloads.wordpress.org/plugin/nextgen-facebook.zip, that *should* fix the issue.

    Thanks,

    js.

    cruzgloriosa

    (@cruzgloriosa)

    HI JS,

    I’m installed dev version, first i haved error, “this folder already exists”…

    Then i checked the “Preserve on Uninstall” option on the Advanced settings page, in WordPress deactivated pluggin, in FTP i renamed the old pluggin folder and upload the new dev version folder and activated this in WordPress.

    As result i have 2 versions of pluggins installed:
    Version 6.7-dev2 (activated)
    Version 6.6 (deactivated)

    And the counter works fine, but only for pages…
    http://www.cruzgloriosa.org/catequesis/
    http://www.cruzgloriosa.org/cantos/

    Not working in posts. All counters (Twitter, FB, G+…) are in 0…
    http://www.cruzgloriosa.org/2013/08/11/el-icono-de-la-transfiguracion-del-senor-explicacion-detallada/
    http://www.cruzgloriosa.org/2013/07/30/jmj-despedida-de-francisco-y-lio-de-otro-francisco/

    Thanks for your help.

    Plugin Author JS Morisset

    (@jsmoriss)

    I’m running out of ideas. Obviously something is getting in the way of the Javascript. Are you sure you tried disabling all the plugins, etc. you could? How about optimization services like CloudFlare etc.? *Something* is messing with their Javascript…

    BTW, you can move the location of the Twitter JavaScript back into the header. 😉

    js.

    cruzgloriosa

    (@cruzgloriosa)

    Hi JS,

    Sure, i disabled all pluggins and test only with NGFB plugging enabled.

    I don’t know CloudFare, i don’t have optimization services installed.

    I move the location of Twitter Javascript into the header, but in plugging settings i have any difficulties with display…

    See image here:
    http://www.cruzgloriosa.org/wp-content/uploads/2013/08/Capture-d’écran-2013-08-16-à-00.05.16.png

    Thanks for your help, i hope we find any solution.

    Plugin Author JS Morisset

    (@jsmoriss)

    Those question marks should be images managed by javascript /jquery to popup contextual help.

    This, plus the problems you’re having with the social buttons (which are largely javascript), points to an issue with javascript on your website.

    Which version of WordPress are you using?

    Thanks,

    js.

    cruzgloriosa

    (@cruzgloriosa)

    Hi,

    I have the lastest WP version ans i’m hosted in DreamHost.

    Plugin Author JS Morisset

    (@jsmoriss)

    I have a WordPress website hosted at Dreamhost, and my Open Graph+ settings pages show the jQuery popup correctly. The fact that javascript / jquery does not work correctly on the settings pages, would indicate a problem with your website. Perhaps you should ask the DreamHost guys to have a look. You could also try and re-install WordPress 3.6 (under Dashboard -> Updates -> Reinstall Now). And to make sure it’s not theme related, you could also try another theme. Something is definitely wrong with your website, so you should certainly track down the cause.

    js.

    cruzgloriosa

    (@cruzgloriosa)

    Hi,

    I’m reinstalled WordPress as you says and nothing…

    Now in posts, only Google+ counter works (any suggestion for recuperate Facebook counter?); in pages all counters are working.

    I asked in DreamHost forum, i wait the response.

    Thank you.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Twitter counter always = 0’ is closed to new replies.