Support » Plugin: Meta Tag Manager » Twitter Cards

  • I’ve successfully added custom meta tags for all pages as follows, and it’s appearing correctly on home page tweets. I’ve also added meta tags with on a sub page http://knowledgeleadersfunds.com/kldw with a different “twitter:site” (which is different then the home page), but it’s not loading image below… any suggestions?

    <meta name=”twitter:card” content=”summary” />
    <meta name=”twitter:site” content=”@changes” />
    <meta name=”twitter:title” content=”Investing in Knowledge Leaders” />
    <meta name=”twitter:description” content=”Knowledge Leaders’ strategy seeks to transform the Knowledge Effect into portfolio alpha… selects investments on the basis of knowledge intensity.” />
    <meta name=”twitter:image” content=”http://knowledgeleadersfunds.com/wp-content/uploads/2015/03/KEimagesSemi-300×230.jpg” />

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Marcus

    (@netweblogic)

    You seem to have duplicate meta tags, one produced by MTM and the other by your SEO plugin.

    Thnx Marcus – I removed the Yoast SEO social info, changed MTM settings to home page only and still the page I added specific meta tags to is not displaying correctly: http://knowledgeleadersfunds.com/kldw/ .

    Plugin Author Marcus

    (@netweblogic)

    The only other thing I can think of is the og: fields generated by Yoast.

    I’m not able to help you with debugging specific meta fields and services like twitter, what I can help is making sure MTM generates the tags as they are meant to be generated, which are in your source code:

    
    <!-- Meta Tag Manager -->
    <meta name="twitter:card" content="summary" />
    <meta name="twitter:site" content="@KLDWETF" />
    <meta name="twitter:title" content="KDLW - Knowledge Leaders Funds" />
    <meta name="twitter:description" content="Knowledge Leaders Developed World ETF" />
    <meta name="twitter:image" content="http://knowledgeleadersfunds.com/wp-content/uploads/2015/03/KEimagesSemi-300x230.jpg" />
    <!-- / Meta Tag Manager -->
    

    It looks like they are fine to me, although I don’t know whether the names of these tags are correct since you manually add them yourself, but that is specific to what twitter requires you to enter.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.