Support » Plugin: Yoast SEO » Twitter card not showing summary with large image

  • Resolved Summer Yule

    (@summeryulenutrition)


    I have Yoast set to “summary with large image” as the default Twitter card. However, all posts are showing the summary only (small images). This is true regardless of how I post to Twitter (e.g., direct Tweet of a link, using the sassy social share twitter button, or when auto-posting from Jetpack).

    I’ve been in touch with Jetpack and they’ve told me this is an issue with Yoast. I am hoping that you can help me to resolve this issue, thank you!

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hi @summeryulenutrition,

    Thank you for reaching out.

    We checked the page you are referring too and found the cause of this. Besides Yoast SEO, any other plugin or your theme is outputting SEO tags on your site and in there, it shows the twitter:card to be the summary without the large image. See image here:

    Can you please check which plugin or if your theme is outputting these and disable this as search engines might be confused with duplicate meta tags.

    Thread Starter Summer Yule

    (@summeryulenutrition)

    Hello,

    Thank you for getting back to me so quickly. I contacted Jetpack first because I agree that it does not appear that Yoast is controlling those tags. Jetpack sent me this image:
    https://d.pr/i/yrZyYq

    and said “Looking closer, Yoast is controlling these tags. In fact, Jetpack is designed to not interfere when Yoast is active. You can double-check this by deactivate Jetpack and testing again.

    If you’re still experiencing trouble with Jetpack off, try reaching out to Yoast support.”

    When I look on my staging site, the Twitter card does not change when I change themes or deactivate Jetpack. I am unsure what to try next.

    Thank you again for your help. If there is a simple piece of code I could insert in the CSS box to change the Twitter card, that would be great.

    Best,
    Summer

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @summeryulenutrition

    Just to be sure, we would like to rule out any plugin or theme conflicts that may occur. The fastest way to do this is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Nineteen. Test this on your development or staging site, if you have one.

    If not, we recommend using the Health Check & Troubleshooting plugin. This plugin allows you to run a conflict check without affecting normal visitors to your site.

    As we can imagine that you’re unfamiliar with checking for conflicts, we’d like to point you to a step-by-step guide that will walk you through the process: How to check for plugin conflicts.

    Could you confirm if the issue occurs with a default theme and only the Yoast SEO plugin activated? Or if not, could you then activate your plugins and preferred theme one by one in order to locate the conflict?

    Thread Starter Summer Yule

    (@summeryulenutrition)

    Hello,

    I wanted to provide an update that I was able to fix the issue by changing the “social meta data” settings in the Blog2Social plugin and turning off wp.me shortcodes in Jetpack. I can see the correct tag in the Yoast section now and my test Tweet used the large image.

    I am so thankful that this was a relatively easy fix. Thank you for your help! Summer

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Twitter card not showing summary with large image’ is closed to new replies.