WordPress.org

Support

Support » Plugins and Hacks » Twitter Authorization

Twitter Authorization

  • Hi Tommy,

    Enjoying the plug-in! The Facebook authorization went quite smoothly, but Twitter auth has been less so. When I click the “Sign in with Twitter” button, the following message appears on the Twitter site:

    https://twitter.com/oauth/authorize?oauth_token=

    “Woah there!
    This page is no longer valid. It looks like someone already used the token information you provided. Please return to the site that sent you to this page and try again … it was probably an honest mistake.”

    Can you offer any advice?

    Thank you for your help.

    Tom

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Tommy

    @akisbis

    yeah that url occured sometines with the old version of the plugin, you can refresh the page and the url will be correct… With 0.4 (and newer), you should never get that url again.

    Please update your plugin, and then try again. Let me know if it works.

    I’m running 0.4.3 now. Tried to refresh the page but no luck. Is there anything I need to do from the Twitter side?

    Plugin Author Tommy

    @akisbis

    You could check into your apps Twitter if there is already WordSocial, and revoke this access. But it should cause any trouble if it’s the case.

    Maybe I could send you an other version of the plugin, which show the error message from Twitter, so we can know what’s the problem.

    Can I use the email I see in your login ?

    Hi Tommy, Yes, the email above will work. Thanks again for your time.

    HarborSiteBar

    @harborsitebar

    Having a problem registering this application with my Twitter account. It seems to connect with Twitter, I put in the correct Login and Password and then it just returns back to WordSocial. I have the Facebook portion working correctly but, not the Twitter.

    Please advise.

    Rob Roy

    @danetidwell

    /Having the same issue as roscoe above. Twitter authorization gives error, refreshing the page doesn’t do anything, the app isn’t listed as connected to twitter in my profile.

    Plugin Author Tommy

    @akisbis

    Okay, let’s see after my update (synday evering) if you still have that issue. (I hope not!)

    I’m sorry for this, but it’s really hard for me to find the cause, because it works fine for me :s

    Having a somewhat similar problem running version 0.5.0.
    Facebook connect works fine but Twitter is bugging:

    1)Under the Twitter tab in the WordSocial plugin I press “sign in with twitter”
    2)Occasionally get the “Woah There”
    3)Otherwise Twitter asks me to Authorize WordSocial
    4)I Authorize App
    5)Twitter says “Redirecting you back to the application. This may take a few moments.”
    6) I get redirected back, but not to the WordSocial plugin, but rather the GA plugin – which happen to be the plugin listed before WordSocial under Settings in WP Controlpanel
    7)Back in WordSocial in the Twitter tab it still says “If you want to auto-publish your blog posts/pages on your Twitter account, you have to authorize WordSocial to publish on it” and WordSocial isnt listed as an Authorized app when looking at Settings on Twitter.

    None the less, keep up the great job on the plugin – it’s definitely filling a need!

    Has there been any resolution? I’m having the same issue currently as nazhady. Thank you.

    Plugin Author Tommy

    @akisbis

    Need more testing on my hand, because I never encountered that issue but you’re several having it :s

    Any resolution to this problem?

    Plugin Author Tommy

    @akisbis

    I contacted the author of the GA plugin, because the problem is inside his plugin and not mine.

    I can’t do anything for that.

    Hello, I’m having the same problem. I don’t use a GA plugin. When i try to link up to Twitter, everything looks like its working, then it sends me back to the Wordsocial plugin screen but the twitter still says it needs to be activated.

    Hi Guys I’ve the same issue as nazhady. I’ve tried with a solution and it work’s fine for me.

    I turned off GA plugin, then I connect the WordSocial plug with twitter and after that I Reactivate GA plugin.

    Every works fine now (so far)

    Hope it helps!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Twitter Authorization’ is closed to new replies.