Support » Themes and Templates » TwentyEleven – Hide/remove page title

  • Hi,
    Having problems with the titles on my pages, for some reason the titles are a larger font size on the other pages compared to my index page. This is not a problem really as I would like to remove the page titles from each page except the index page.

    I would also like to hide/remove the Reply button on my index page. Not even sure where it came from, it appeared after I deleted the speech bubble comment button.

    My blog address is : http://www.kirstiebenbow.co.uk

    Many thanks in advance.

Viewing 15 replies - 1 through 15 (of 18 total)
  • I was wondering the same thing so I was messing with all the files in the TwentyEleven theme.

    If you edit the content-page.php file and remove <h1 class="entry-title"><?php the_title(); ?></h1>. That’ll remove the page titles. Not sure how to do it for only some pages though. I like it done for all my pages. Hope this helps you somehow.

    vickie

    (@vickieflores)


    Thanks marlenafell …it helps 🙂
    It’d be great if anyone figures out how to do it just for selected pages if they could update?

    Michael

    (@alchymyth)


    Forum Moderator


    for selected pages, use can css and the output of body_class; i.e. the .page-id-237 css class, which is individual for each page (the number is the page ID).

    add something like this to style.css of the child theme:

    example:
    .page-id-237 .entry-title { display: none; }

    (obviously, you need to leave the line in content-page.php, mentioned in @marlenafell‘s reply)

    vickie

    (@vickieflores)


    Perfect, thanks a lot 🙂

    Very nice alchmyth! 😀 Glad to help guys. Really loving TwentyEleven.

    perfect thankyou!

    any idea how to remove the ‘Reply’ button on the post on my front page?
    thanks

    http://www.kirstiebenbow.co.uk

    Michael

    (@alchymyth)


    Forum Moderator


    @stokeyreggae
    have you disabled the comments for that post? and/or for posts in general?

    I don’t think I have, how do I go about this?

    Michael

    (@alchymyth)


    Forum Moderator


    a:
    http://codex.wordpress.org/Settings_Discussion_Screen

    b:
    and you also have to check if comments are enabled; either using ‘quick-edit’ for each post and page; or look below the post/page editor for a ‘discussion’ area where you can disable the comments for this post/page (if this does not show, click ‘screen options’ near the top right, tick ‘discussion’, then scroll back down where the ‘discussion’ area should now be visible.

    if comments are disabled, the ‘reply’ should not show.

    Fantastic, thanks for the quick reply.
    All I needed to to was disable comments in quick edit on the post.

    thanks again!

    Yep – removing the <h1 class=”entry-title”><?php the_title(); ?></h1> from the content-page.php in the theme worked.

    But I must stress that I created a child theme, and removed it from that.

    Basically, copy the content-page.php, insert it into your child theme’s folder, and remove <h1 class=”entry-title”><?php the_title(); ?></h1> from the child theme’s version.

    Alchymyth, is it possible to remove the “Reply” but still have comments show?

    I would like to remove Home and associated page from my twenty eleven theme.

    Brian

    esmi

    (@esmi)


    Forum Moderator


    Please post a new topic.

    Yep – removing the <h1 class=”entry-title”><?php the_title(); ?></h1> from the content-page.php in the theme worked.

    Hi Symbolism, i know this thread has been idle for a while but i was just wondering, removing that line of code, does it leave a gap above the Page text? I am trying to get a slider gallery to sit right underneath the menu but i seem to have a gap of about 20px.

    any tips?

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘TwentyEleven – Hide/remove page title’ is closed to new replies.