Support » Plugin: WP Custom Login » Twenty-Twelve background problem after WP3.9 update

  • Resolved Nick1H

    (@nick1h)


    Hi,
    I use a child of the Twenty-Twelve theme.
    After upgrading WP from V3.8.3 to V3.9 the wp-custom-login pages have a blank margin above the content panel which should be part of the background. This is only on the custom login pages, the rest of the site looks fine.
    I tried disabling the child theme and reverting to the stock Twenty-Twelve but the problem is the same.
    You can see the problem at http://www.ladebraes.net (the site isn’t live yet).
    Any help welcome.

    https://wordpress.org/plugins/wp-custom-login/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Ninos

    (@ninos-ego)

    Just add in your custom wp-custom-login.css following entry:

    body .site {
    margin-top: 0;
    }

    Thanks.
    I did that (with !important) and it removed the top margin ok but it still doesn’t look like the regular pages which have the margin filled in with the background.
    Still, it looks better now.

    Plugin Author Ninos

    (@ninos-ego)

    You should lern CSS 😀

    body.custom-background {
    background-color: transparent;
    }

    CSS is easy. Unfortunately your suggestion does not work; I already tried messing about with the custom-background class.

    It may have something to do with this error which shows up in Firebug, only on the custom login page:
    “TypeError: element is null
    element.parentNode.removeChild(element);”
    from: “wp-admin/&reauth=1” (line 21)

    Plugin Author Ninos

    (@ninos-ego)

    than with the important attribute. For me it’s working fine.
    You can also just define the body element like this (Maybe here you need definitely the important attribute):

    body {
    background-color: transparent !important;
    }

    Awesome! That fixed it. Thanks.
    Really like your plugin.

    Plugin Author Ninos

    (@ninos-ego)

    Perfect, thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Twenty-Twelve background problem after WP3.9 update’ is closed to new replies.