Support » Fixing WordPress » Twenty Thirteen custom header select image not working

  • Resolved larsomatic


    I have a fresh install of WP 3.6 hosted at – the URL is

    The active theme is Twenty Thirteen. I use wp-admin and navigate in the left nav to Appearance > Header; in the “Select Image” area I either “choose an image from your computer”, select an image and click “Upload”, or I “choose an image from your media library”.

    Either way, the next screen shows the left nav and WordPress header but otherwise is blank. The theme header image remains unchanged. If I uploaded an image, it shows up in wp-content/uploads/2013/08 as expected. If I select an image from my media library I can browse to any of the previously-uploaded images, but again: next page is empty except for left nav and header, and the change is not applied.

    Having searched the forums, I have deactivated all plugins, re-installed WP 3.6, turned on WP-DEBUG and WP_DEBUG_LOG and changed WP_MEMORY_LIMIT to 96M in wp-config.php, switched themes back and forth between Twenty Twelve and Twenty Thirteen — no change in behaviour. I have tried all these things in many different permutations.

    I do not get any PHP errors nor server errors (except 404 when I manually rename files via FTP). As far as I can tell, all permissions are correct and I can upload, edit and delete media images freely in wp-admin.

    I have tried a variety of JPEG and PNG images, in sizes of 1600 x 230 (the size used by Twenty Thirteen) and other sizes. In Twenty Thirteen the cropping screen never shows up; in Twenty Twelve it did, but again the change was not applied and the default Twenty Twelve header (with no image) continued to be shown.

    I have tried Chrome and Firefox on 2 different Macs (each running MacOS 10.8.4) and tried from Windows as well — same result.

    My background: lots of server and coding experience outside of PHP, some PHP experience; this is my very first WordPress site.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hi, unfortunate that this should be your first experience with WordPress.

    Can you insert images in regular posts?

    Thanks, Mike.

    Yes, I can. I hadn’t actually tried until you asked… Using wp-admin I created a new post and used the “Add Media” button to place an image previously added to my media library.

    The result:

    Hmm ok.

    If this is the only problem you are running into at the moment you might consider replacing the actual default header image itself for now. You can then go ahead and revisit this problem.

    I’ve tried to recreate your problem, but onfortunalely I havent been able to.

    I will post to my hosting provider’s support next, in case it’s something environment-related or tied to my choices during installation.

    Mike, your advice is good, but I want to WIN. 🙂 More seriously, this issue makes me nervous what will turn up next, and getting it solved will be good for my relationship with WordPress.

    I ran across instructions for doing your suggestion (replace one of the default theme header images with my own) in other posts and am sure that would work.

    I’m getting this output when I attempt to set a header images from my image library:

    Image could not be processed. Please go back and try again.

    I was excited to find that the controls were there and it seemed to work, but then I got this message. Does that sound like a permissions issue? If so, which folder is it?


    * I am able to upload images from my local drive.

    UPDATE to original issue: now it works. Short version: used Chrome on Windows instead of Mac browsers.

    When I went to reproduce issue for tech support at my hosting provider, the Custom Header > Header Image > Select an image… feature worked after all.

    The only difference was that I worked from a Windows browser (Win 7, Chrome Version 28.0.1500.95 m) whereas I tried earlier from Chrome, Firefox and Safari on two different Macs (MacOS X 10.8.4 “Mountain Lion”). I had also tried a Windows browser but now don’t remember which one and didn’t test as thoroughly on it anyway.

    I will re-try on a Mac tonight. I don’t know whether to hope it will work or not…

    I am having the same problem with the header image not working on the twenty thirteen theme. To get around it I am using a plugin called “twenty thirteen header animations” – I can only get one header to show although there are 4 images to choose from – I I am not good with PHP.I am also having problems seeing my media library images in the same theme.

    @kenbird – this thread is marked resolved – please start your own per the forum guidelines –

    And if you need help with a plugin, you need to post on the plugin’s own sub-forum – find the plugin here:

    Go to it’s own page and click on the support tab for that plugin.

    Noted – my apology.

    No worries – just want you to get an answer, and for other people to be able to find previous questions.

    Only replying here because I think I have something to contribute as per the rules of the community.

    I had identical problem and solved it by renaming the image and uploading again that I was trying to get to load into Twenty Thirteen. If I give even the same image a different version name each time, the header image updates as it should. Hope this helps someone.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Twenty Thirteen custom header select image not working’ is closed to new replies.