Support » Themes and Templates » Twenty Eleven website not showing in IE10

  • Carley

    (@carleycwddcomau)


    My new website works in IE9 but not IE10. The only thing that appears is the background: http://www.yarrawongamerino.com.au
    I thought it might be the hgroup tag which is supposedly obsolete, if so how do I go about removing it from the Twently Eleven theme?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Check whether the issue persists on the theme’s demo site. If it doesn’t, try deactivating plugins to explore whether any could be responsible.

    Carley

    (@carleycwddcomau)

    No the demo site doesn’t work in IE10 either. And I deactivated the only plugin I had installed but no luck. I might just have to change themes 🙁 Thanks anyway Andrew.

    No the demo site doesn’t work in IE10 either.

    Could it be that Compatibility mode is on by mistake ?

    Fix site display problems with Compatibility View IE10
    http://windows.microsoft.com/en-us/internet-explorer/use-compatibility-view#ie=ie-10

    Carley

    (@carleycwddcomau)

    No that doesn’t make any difference whether it’s on or off.
    I still get the error “A problem displaying http://www.yarrawongamerino.com.au cause IE to refresh the webpage using Compatiblity View.”

    I also noticed in the code that there is no code block that references IE10 but there is for IE6-9. Here’s the code that I can see:

    <!DOCTYPE html>
    <!--[if IE 6]>
    <html id="ie6" lang="en-US">
    <![endif]-->
    <!--[if IE 7]>
    <html id="ie7" lang="en-US">
    <![endif]-->
    <!--[if IE 8]>
    <html id="ie8" lang="en-US">
    <![endif]-->
    <!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
    <html lang="en-US">
    <!--<![endif]-->
    <head>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width" />
    .
    .
    <!--[if lt IE 9]>
    <script src="http://www.yarrawongamerino.com.au/wp-content/themes/twentyeleven/js/html5.js" type="text/javascript"></script>
    <![endif]-->

    Those code blocks wouldn’t be the difference — they’re for including code to compensate for some of the stuff that’s missing from earlier IE versions, and anyway, IE 10 (like all non-IE browsers) doesn’t even recognize such code blocks any more.

    hgroup is also not the issue — browsers deal with tags they don’t recognize by just ignoring them as if they weren’t there at all (and anyway, that particular tag is supported by both IE9 and IE10).

    Both yarrawongamerino.com.au and the Twenty Eleven demo site work in IE10 for me.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Twenty Eleven website not showing in IE10’ is closed to new replies.