Support » Plugins » Twenty-Eleven Warning: Missing required field "updated"

  • Resolved sdpate48


    I am getting the rich snippets message “Warning: Missing required field “updated””

    None of the fixes for twenty-eleven have worked.

    The I checked the source on one of my posts” Windows 8 You and Me Together”

    On line 194 is the HTML code “<style type=”text/css”><span class=”updated”><?php echo get_the_date(); ?> </span></style>

    And on 335 is the value “<span class=”updated”>December 10, 2012 </span>”

    So the value “updated” is there but the Google snippets tool does not see it.

    Can anyone tell me where my problem is? Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi sdpate,

    I just had a look at your website. Google is looking for the “updated” class in <time class="entry-date"

    I ran into the same problem myself where I could find no up to date tutorials on how to fix this, so I delved into the code and resolved it myself. Hopefully the tutorial I wrote can save people some time on this issue.

    This was answered by Daniel Marquard

    Essentially the problem is the “time class=”entry-date””

    needs to match Google’s spec “time class=”entry-date updated””

    functions.php line 581

    and thanks.

    HI All,
    Could you please anyone help me to solve the same issue, I already updated as above, but still the same issue.

    Really appreciate the help.
    function twentyten_posted_on() {
    printf( __( ‘<span class=”%1$s”>Posted on</span> %2$s <span class=”meta-sep”>by</span> %3$s’, ‘twentyten’ ),
    ‘meta-prep meta-prep-author’,
    sprintf( ‘<span class=”entry-date updated”>%3$s</span>‘,
    esc_attr( get_the_time() ),
    sprintf( ‘<span class=”author vcard”>%3$s</span>’,
    get_author_posts_url( get_the_author_meta( ‘ID’ ) ),
    esc_attr( sprintf( __( ‘View all posts by %s’, ‘twentyten’ ), get_the_author() ) ),

    if ( ! function_exists( ‘twentyten_posted_in’ ) ) :

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Twenty-Eleven Warning: Missing required field "updated"’ is closed to new replies.