Support » Themes and Templates » Twenty-Eleven child-theme not showing up for activation

  • Resolved AlexanderSchaefer

    (@alexanderschaefer)


    Hey everybody out there,

    sorry for bothering, but i kinda searched google for hours not finding anything helpful. Either it’s a new problem or (what is more likely) i’m an idiot, because i’m like completely new to blogging and especially wordpress.

    My problem: My child-theme is not showing up for activation when i try to in the design->themes section.

    I’m trying to set up a child-theme for the twenty-eleven theme at my domain Exposure Of Sound. Checked the official WP.org tutorial, and it seemed simple to me. So i created a new directory at “/wp-content/themes” called “twentyeleven-child”. I placed only the style.css in the directory, including following code:

    /*
    Theme Name:     twentyeleven-child
    Theme URI:
    Description:    Child theme for the Twenty Eleven theme
    Author:         Your name here
    Author URI:     http://www.exposureofsound.de/uber-mich/
    Template:       twentyeleven
    Version:        0.1.0
    */
    
    @import url("../twentyeleven/style.css");

    Theres nothing else in the directory.
    Different hits at google suggested:
    1. Checking template name (Same as parent theme folder name)
    2. Problems with wrong line break type (only working with Windows cr, or unix lf)
    3. Checking if there’s any broken theme link at the bottom of the page.

    Checked everything of the above, even tried the “One-Click Child Theme”-Plugin. It essentially did what i wanted, but i couldn’t find the ftp-directory where the Plugin stored the child theme.
    And in fact i want to understand what i’m missing, and i would rather like to do something myself, than to have another plugin.

    Hopefully thats enough information for you to try to help me. I really couldn’t find anything useful with google or boardsearch, and maybe i’m missing something extraordinary dumb, but i would appreciate some help.

    Best Regards
    Alex

Viewing 7 replies - 1 through 7 (of 7 total)
  • esmi

    (@esmi)

    Forum Moderator

    Thank you very much for the quick answer.
    Installed it, works, but still can’t see the theme-directory in my ftp-client. But i think THATS a problem of my system. Will figure something out for that.

    Any idea why it didn’t work the way it is explained on the WP codexpage?

    Regards
    Alex

    esmi

    (@esmi)

    Forum Moderator

    Based upon the example you posted, no idea. Perhaps you were using something other than a plain text editor?

    Hey esmi,

    i didn’t use a plain text editor. I used Notepad++ which i know as a powerful CSS-Editor. And since the only file i had to create was a .css it seemed suitable to me.

    Basically the problem is solved, but i’m really curious. If my questioning annoys you just tell… 😉

    esmi

    (@esmi)

    Forum Moderator

    Not at all. It’s just that I’m at a bit of a loss to explain why you had problems initially.

    Okay,…
    The Link to the Child Theme Zip was a big help though.
    Maybe i find out what was wrong when i get a bit more familiar with WP.

    Thanks a lot.
    Best regard.

    By the way. Got it. Problem was caused by stupidity. Not worth explaining.
    But thanks anyways. 😀

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Twenty-Eleven child-theme not showing up for activation’ is closed to new replies.