Support » Plugin: Twitter Tools » Tweets won't show on page

  • markenhannekeliefhebber



    since everyone seems able to get Twitter Tools working it’s probably something easy, but I can’t seem to figure it out. Can anyone help me with this?

    – I installed Twitter Tools and Social.
    Twitter Tools has me connected with my Twitter account
    Social has me connected with my Twitter account.
    – Twitter shows me at the aplication settings it has a connection with Social Proxy by Mailchimp
    – On my WordPress site I have added Twitter Tools as/in a widget in the 2nd Footer on my main page (
    – It does show the titel of the footer and the following message: “No tweets available at the moment”
    – Whatever I try (waiting, double checking, clicking “download Tweets now” etc) it doesn’t show my Tweets…

    Does anyone know what I’m doing wrong? My only goal is to show my latest Tweets on the page, I won’t be using the not the blogpost to Tweet option. It might be relevant to mention that earlier on other Twitter plugins didn’t show any Tweets also… What is it woth me and Twitter/Wordpress…


Viewing 4 replies - 1 through 4 (of 4 total)
  • When you upgrade, it automatically disables your account. In your twitter tools setting, check to see if next to your account name is the word “disabled,” click on it to enable and see if that fixes it.

    I have the same problem and my account seems to be enabled.

    On the Twitter Tools settings page:
    Show admin screen for tweets: Yes
    Create URLs for tweets: no
    Give Twitter Tools Credit: no – I may change this if I ever get it to work
    Debug logging: Enabled
    Accounts:shows my account and the appropriate logo, Enabled is checked
    Create blog posts from tweets is not checked (i don’t want this service for now)

    On the Social Settings page:
    Accounts:my twitter account is listed, with the logo, and default is checked
    Facebook: i did not set this up as I don’t want this yet
    Broadcast is on by default: yes
    Post broadcast format: Article just added: {title}: {url}
    Comment broadcast format: {content} {url}
    Advanced Options:
    Misc: Disable Socials comment display is checked
    Disable Socials broadcasting feature is not checked
    Twitter default API account lists my account in the box
    Fetch New Comments: Never is selected
    Debug Mode: off is selected

    Under the Tweets menu on the left:
    Tweets – includes all my current tweets
    accounts – shows my account in the top left under popular tags and lists my account in the chart at right. It also includes a plug that is my account with a -2 after.
    Mentions – lists one
    Hashtags – currently empty

    The widget:
    Title: Recent Tweets
    Account: lists my account in the box
    How many tweets: 5
    include retweets: no
    include replies: no

    The software does allow for tweets to be generated when I write a new post. It appears as though the widget is not working. On the webpage, it shows the title and then lists no tweets available at the moment.

    I have tried all kinds of options based on things I have read online. I deleted the widget and added it again. I changed misc options and saved. I just hit resave. Nothing seems to be working.

    Help please…
    For reference: and the widget is being used in the footer.



    Thanx a lot PhDeviate!!! You wouldn’t believe how much time I wasted on this. All the time, so close and yet so far! So simple all of the time…

    It works! Mark

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Tweets won't show on page’ is closed to new replies.