WordPress.org

Support

Support » Plugins and Hacks » Twitter Widget Pro » [Resolved] Tweets not updating

[Resolved] Tweets not updating

Viewing 15 replies - 1 through 15 (of 31 total)
  • Had the exact same thing happen. May 8th. No clue as to why. I ended up making a new Twitter app, getting a new APP key, etc, and trying again. It’s the strangest thing, if I change the amount of Tweets to show in a feed, say 5, it will go get the most recent Tweets, but then never update. If I go back to 1, where I had it before, it goes right back to the 1 tweet I had May 8th. It’s almost like it caches the request.

    Same problem here, cannot find a way to fix it. I have the plugin on a client’s website and they are not pleased about it being frozen. Please find a fix asap!!!!

    FYI Just updated the plugin and this problem still exists

    Exactly the same problem – single tweet shown hasn’t updated for 3 days but if I change to showing 3, it shows latest 3 fine. Go back to 1 and it reverts back to the really old one.

    Also, the reason I’m using this plugin is to display tweets from a list but despite selecting that option it’s just getting them directly from the account owning the list.

    Any ideas greatly appreciated! I’m running the latest version of the plugin.

    Iā€™d like to add my voice to this. Same issue here.

    Really need an answer to this. Would rather not drop this plugin but this is getting silly, could really do with a fix to this fundamental issue.

    I also have this issue, described as above, 1 tweet only pulls in an old tweet, change to 3 and new ones appear…
    This site is going live today and I would rather not have to switch plugins so late on..
    Please advise asap!

    I have tried the hack to the version 2.5.4 as per the forum’s suggestion and now it works fine http://wordpress.org/support/topic/plugin-twitter-widget-pro-tweets-not-updating-hosting-incompatibility-with-tlc-transients

    I tried to add the host entry to enable HTTP lookup which is not helpful so went with the code change.

    How did you manage that? Is it still working now?

    I tried reading the thread and came to do the following (which did not work):

    1. Open file ‘tlc-transients.php’
    2. Line 179 says: “return $transient;”
    3. Replace it with the solution given in the thread:

    return tlc_transient( $key )
    			->prevent_background()
    			->expires_in( 300 ) // cache for 5 minutes
    			->updates_with( array( $this, 'parseFeed' ), array( $widgetOptions ) )
    			->get();

    This did nothing. Is this correct? Or did u follow other steps? Please advice!

    Or an other similar plugin, i really need to get this working

    Hi Guys
    I updated the plugin using the one for download here: http://oikos.org.uk/2012/03/tech-notes-twitter-widget-pro-not-updating-for-heart-internet-users/ and that seemed to work.

    I’m having the same issue.

    Currently within my settings I have “How many items would you like to display?” set to “3” and it’s displaying the 3 most recent Tweets.

    However when I switch to “2” (which is how we had it two days ago and now we’re having this problem) it shows 1 Tweet that’s over 9 hours old.

    When I select “1” it shows 1 Tweet that’s REALLY old.

    Authors, please fix this. This Twitter Widget was PERFECT before this. We’re begging you, CHECK YOUR SUPPORT FORUMS DAILY. Jeeze.

    Thanks, did you replace it as an whole.

    I did that and no luck here, same issue still exists.. no updates. Pull in latest tweet dating 27th of may.

    Is the support still working on this issue or has this plugin lost its use?

    For those that are still having this issue, I found a work around.

    Currently I am using RT-Theme 15 on my WordPress Instance. I was able to get 3 of the most recent tweets to show by selecting ‘3’ in “how many tweets would you like to show?’

    Once I had the 3 tweets showing, I isolated the third by using this:

    div.box.dynamic_sidebar.widget div ul li:first-child +li +li {
    	display: none;
    }

    Hope this helps.

    +1

    This is an issue with the _transient_tlc_ keys that TWP writes into the database, so may extended out beyond just problems with Twitter feeds.

    If someone can offer a good solution (or at least a way to determine if the Transient API is working correctly on a WP site, and wp-cron is doing whatever it’s supposed to) that would be really helpful!

    If I manually remove the _transient entry, and refresh – TWP grabs the latest tweet and all is well. However that’s not a viable solution šŸ™‚

    Thanks for any insight people may have.

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘[Resolved] Tweets not updating’ is closed to new replies.
Skip to toolbar