WordPress.org

Support

Support » Plugins and Hacks » Simple Twitter Connect » Tweets not appearing on Twitter

Tweets not appearing on Twitter

  • I have STC Base, Follow Button and Publish plugins enabled, and have signed into my Twitter account via the settings page and authorized my site to tweet, but no tweets are showing up on Twitter. I’ve tried both the auto-tweet on publish and the manual tweet from a post, and neither works.

    Any ideas on how I could fix or even debug this? I tried enabling debug mode via wp-config but it didn’t return any errors related to this plugin. I have confirmed that I have my Twitter application set to read/write/dm access.

    Thanks for your help!

Viewing 1 replies (of 1 total)
  • If not even manual tweets work, then there’s some major problem. See, the manual tweet box doesn’t go through the plugin, it goes direct from your browser to Twitter. So if you can’t tweet from that box, then you have some deeper issue.

    Your application may be read/write now, but was it always that way? Check your own settings screen on twitter, and look to make sure that you authorized it for read-write access and not just read-only access. If it is read-only for you, then you have to deauthorize it, and reauthorize it in the STC settings, making sure it’s read-write.

Viewing 1 replies (of 1 total)
  • The topic ‘Tweets not appearing on Twitter’ is closed to new replies.
Skip to toolbar