• Resolved Julien G.

    (@julien-g)


    Hello,
    Since this morning, tweets are no longer sent when the article is published.

    I have this error message: (No post) » 401 Unauthorized: Authentication credentials were missing or incorrect. (Error Code: 32: Could not authenticate you.)

    How to restore the transmission ?
    Thanks

    • This topic was modified 1 year ago by Julien G..
Viewing 12 replies - 1 through 12 (of 12 total)
  • Alias79

    (@alias79)

    Same here 🙁 Curiously, the API that I had created for years has disappeared, I suppose because everything has been updated to API V2 and a new one has to be created. I’ve already requested it… but I’ve read people saying that WP to Twitter might not be compatible right now with V2.

    Much encouragement to Joseph Dolson!!! All my respect and support, I would even understand if you didn’t want to continue the project. All this mess with the APIs that Twitter has formed is not helping anyone, Twitter itself is the most affected.

    Marc Kranat

    (@marclouis)

    Same here with the pro version which has worked fine for over 5 years

    Thread Starter Julien G.

    (@julien-g)

    Thank you for your feedback, guys.

    I’ll wait for an answer from the dev, but it doesn’t look good. 😅

    Thread Starter Julien G.

    (@julien-g)

    Hello,

    I created new API keys and it works again.
    But until when… 🤔

    gtroquilho

    (@gtroquilho)

    I tried to regenerate the API keys, but didn’t work. I’m receiving an error message: “453: You currently have access to a subset of Twitter API v2 endpoints and limited v1.1 endpoints (e.g. media post, oauth) only. If you need access to this endpoint, you may need a different access level. You can learn more here: https://developer.twitter.com/en/portal/product”

    The plugin can now authenticate, but it can’t post.

    Alias79

    (@alias79)

    I’m in the same situation. Yesterday I left a post on the developers forum (https://twittercommunity.com/t/applicationreceived/191949/23), because there was no way to log into the portal, and they said that they were working on solving that problem. Now is accessible again! I have created the app, and it connects… but it tells me exactly the same as @gtroquilho.

    403 Forbidden: The request is understood, but has been refused by Twitter. (Error Code: 453: You currently have access to a subset of Twitter API v2 endpoints and limited v1.1 endpoints (e.g. media post, oauth) only. If you need access to this endpoint, you may need a different access level. You can learn more here: https://developer.twitter.com/en/portal/product)

    Could it be because WP to Twitter doesn’t support API 2? It seems so, right?

    Thread Starter Julien G.

    (@julien-g)

    Don’t understand.. It works fine for me now after creating new API keys..

    Maybe it works for me because I pay Twitter Blue ? 🤨

    Alias79

    (@alias79)

    Yes, it’s weird. I also have Twitter Blue associated with my website account, that surely has nothing to do with it.

    Plugin Author Joe Dolson

    (@joedolson)

    The behavior of the Twitter API is currently fairly random. Based on the specific information about the API, the plugin currently shouldn’t work; but it does for what seems to be the majority of people. I am unable to identify any clear reason why it works for some people and not for others. For this reason, I’m unable to reasonable provide any meaningful updates for this plugin.

    Alias79

    (@alias79)

    @joedolson Hi Joe! Thanks for answering. So, would this mean that WP to Twitter would not receive any more updates? Whatever you decide, I would like to say for my part, as a user of your plugin, I will support your decision. I understand how complicated it is to carry something, without receiving any benefit in return, and on top of that, problems arise out of nowhere for something that works perfectly. If this is the end of WP to Twitter, I can only tell you that THANK YOU SO MUCH for your work, with all my heart. In 10 years, it’s the plugin that has worked best in all this time. It was simple and totally effective, easy to explain to people. I wish many other things were like that.

    Thread Starter Julien G.

    (@julien-g)

    I couldn’t say better than Alias79.

    This plugin has always worked for me for years, and I’m one of the lucky ones that it still works.

    Whatever your decision, thank you Joe for all this work and the quality of this extension.

    Plugin Author Joe Dolson

    (@joedolson)

    Should be fixed now with version 4.0.0.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Tweets are no longer sent’ is closed to new replies.