Support » Plugin: Social Media Auto Publish » Tweets are getting cut off randomly

  • Resolved carlyjcais

    (@carlyjcais)


    Even though I have not set a character limit with Social Media Auto Publish Settings on my WordPress blog, when I post to Twitter my tweets are getting weirdly cut off.

    79 characters:
    New post up on the blog! 8 Fashion Trends for Spring & Summer 2020 – Read no…

    165 characters:
    Ever wondered #howto sew a #ruffle for your clothing and DIY projects WITHOUT a ruffler foot? Use this #DIY #sewinghack to make easy and perfect ruffles every tim…

    91 characters:
    Improve your #sewing skills in 7 projects that build on the last to make you a #diy quee…

    It’s totally random! I include one photo and the permalink to the post. The Facebook posting is normal.

    What’s going on?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • If you add only {PERMALINK} as message format then the tweet content will be just the image and link not any contents as you mentioned.
    Also there is hash tags in your tweet contents, are you using the premium version or you are adding these by custom message? (overridden at metabox settings of message format at each post).
    Also please check the twitter character length limit you added at settings of SMAP, make sure it is set to 280.
    Please check the message format and let us know ,if the issue persists.
    Thank you.

    carlyjcais

    (@carlyjcais)

    Thank you @anjali94! That was it…I needed to add 280 to the character length settings of SMAP (I had left it blank).
    It is fixed now.
    Thank you for your help!

    • This reply was modified 5 months ago by carlyjcais.

    Thanks for reporting this, @carlyjcais – just writing to say I had the same issue.

    My posts to Twitter were missing the permalink, even though I had {PERMALINK} in the body.

    Setting ‘SMAP’ to 280 fixed the issue (mine was blank too).

    I suggest the plugin should default to 280 rather than making us specify in future.

    But thanks for the great plugin!

    PS: I should say I was on version 2.4.0, and this may now have been fixed in version 2.4.1. (“Minor bugs fixed” in the changenotes).

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.