WordPress.org

Support

[Resolved] "Tweet" word appears in my excerpts!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author JS Morisset

    @jsmoriss

    Well, that’s not good… I can have a look, but I’ll need the URL to an example page, and for you to turn on debug mode from the Advanced settings page, as described in the forum sticky: http://wordpress.org/support/topic/please-read-before-posting-about-an-issue?replies=1

    Thanks,

    js.

    elmalak

    @elmalak

    Hi,
    Thank you for getting back to me so quickly.

    Here is the URL:
    http://www.103graphics.com/
    You will find 6 articles on this page, number 5&6 show the problem as I didn’t set manual excerpts for them.

    I’ve turned on the Debug mode like you asked.

    Regards,

    Plugin Author JS Morisset

    @jsmoriss

    Ah, well, that’s interesting…

    So most themes usually access the excerpt using get_the_excerpt() or something similar (which constructs and excerpt if one hasn’t been entered), but for some reason, your theme author decided to use get_the_content() and trim the full content himself instead! Since you add social buttons to the top of your content, your theme strips the html, but the twitter button also contains some text (the word “Tweet”), so that gets left behind.

    It’s always better for authors to use standard WordPress functions and methods, or you get weird behavior like this.

    Luckily the “Tweet” text is rather optional and unnecessary, so I’ve removed it. There’s no point in creating a new version of the plugin for this, so if you uninstall and reinstall the plugin, you should be good. Don’t forget to check the Preserve on Uninstall option before removing the plugin. đŸ˜‰ (see http://surniaulula.com/codex/plugins/nextgen-facebook/how-to/uninstall-the-plugin/).

    js.

    elmalak

    @elmalak

    Thanks for the fix, I tried it and things now look great.

    I had one more issue that I noticed a couple of days ago and wanted to let you know about.

    I had a conflict with this plugin, http://wordpress.org/plugins/easy-pricing-tables/ that I use on my site here,

    http://www.103graphics.com/wordpress-maintenance-service/
    And what it did was prevent the page from loading completely.

    I had contacted the plugin author and he advised me to un-check the Apply Content filters in your Advanced settings and that fixed it, but I am not sure if that affects my site in other ways or not, but just wanted to tell you about it.

    Regards,

    Plugin Author JS Morisset

    @jsmoriss

    From the Other Notes:

    WordPress allows plugins and themes to hook into various filters, which are then used by WordPress to expand shortcodes, etc. WordPress generally calls a filter (like ‘the_content’) once to expand text for the webpage. As a consequence, some authors mistakenly assume that a filter they have created will only be executed once. WordPress filters are available to any theme and/or plugin that needs to expand text (title, excerpt, content, etc.), which NGFB Open Graph+ uses to provide a complete and accurate meta tag description (as an example).

    http://surniaulula.com/codex/plugins/nextgen-facebook/notes/debugging-and-problem-solving/

    Thanks for confirming that your issue is now fixed – I’ll mark issue as resolved.

    js.

    elmalak

    @elmalak

    Thank you for your help and support.

    I appreciate it.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] "Tweet" word appears in my excerpts!’ is closed to new replies.
Skip to toolbar