WordPress.org

Support

Support » Plugins and Hacks » Tweet This » [Resolved] Tweet This 1.8.3 giving HTTP 404

[Resolved] Tweet This 1.8.3 giving HTTP 404

  • I have had a working Tweet This and had posted sucessfully a couple of days ago. Now when I post new or update on a failed “tweet this” I get Tweet failed. Twitter returned HTTP 404. Check your OAuth settings and re-save this post to try again.

    I have clicked on “Test Twitter OAuth” and it was successfull. I have a “Write Tweet” option but when I try to send a tweet I get “Tweet failed: Twitter returned HTTP 404.”

    Has the url needed for tweeting changed?

    http://wordpress.org/extend/plugins/tweet-this/

Viewing 15 replies - 1 through 15 (of 16 total)
  • The same thing has just happened to me, it was working, must be something up at their end? Can anyone else test the auto posting and confirm please?

    There is some stuff out there about twitter and API changes. Perhaps that has something to do with it?

    Tweet This no longer appears in the wordpress plugin pages, or am I not looking in the right place?

    Same probleme here ! Auto post doesn’t Work and plugin isn’t any more on WordPress.org

    Ive got no idea what to do about this.

    Same here

    The solution is:
    Edit

    /plugins/tweet-this/tweet-this.php

    and change line 89 from

    define('TT_API_POST_STATUS', 'http://twitter.com/statuses/update.json');

    to

    define('TT_API_POST_STATUS', 'https://api.twitter.com/1/statuses/update.json');

    March 2013 they will again change something, to we will have to change to …/1.1/…
    See: https://dev.twitter.com/discussions/10803

    Thanks noapi1, it’s working !!!

    Well done, noapi1

    Thanks for posting the fix.

    I’m not sure if it will help me but I have subscribed to the twitter REST API v1.1 Discussions.

    If Tweet This is no longer on the plugin list I may have to change to something else before March 2013.

    Excellent, thanks noapi1!

    Awesome! Worked for me!

    Just a quick one, Twitter have now retired their API ver 1.0, replacing it with ver 1.1. So, in order to keep using this magnificent plugin, you now need to change the line:

    define('TT_API_POST_STATUS', 'https://api.twitter.com/1/statuses/update.json');

    to read:

    define('TT_API_POST_STATUS', 'https://api.twitter.com/1.1/statuses/update.json');

    There you go, it’s as simple as that… well it worked for me!

    Good answer cosmicjellybaby, but it didn’t work for me. I realized the answer was centered around the API version, but changing it in the main php file wasn’t good enough. So for those of you still having trouble…MAKE SURE you do what cosmicjellybaby advises, but IN ADDITION, look in the lib folder, open the twitteroauth.php file and go to line 23

    public $host = "https://api.twitter.com/1/";

    change it to read

    public $host = "https://api.twitter.com/1.1/";

    Now you should be back in business.

    How very odd, I have made the single change on one of my sites and it worked as I mentioned. HOWEVER, I replicated that single step on another site and lo and behold as JHardin1112 states, the change to the twitteroauth.php file in the lib folder was also required.

    It gets stranger and stranger, now getting 301 error rather than 404 (with the above changes). OAuth settings confirmed as correct. Really annoyed because I can’t see anything out there that does the job of Tweet This as well as Tweet This did…

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] Tweet This 1.8.3 giving HTTP 404’ is closed to new replies.
Skip to toolbar