WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Tweet still gets sent with "Don't tweet this post" selected

[Resolved] Tweet still gets sent with "Don't tweet this post" selected

Viewing 4 replies - 1 through 4 (of 4 total)
  • I’ve tracked down the issue to line 1303:

    if ( empty($_POST) || ( isset( $_POST['original_post_status'] ) && $_POST['original_post_status'] == 'auto-draft' ) || ( defined('DOING_AUTOSAVE') && DOING_AUTOSAVE ) || wp_is_post_revision($id) || isset($_POS T['_inline_edit']) ) { return $id; }

    If I change that line by commenting out the logic that checks for the auto-draft status like so:

    if ( empty($_POST) || /*( isset( $_POST['original_post_status'] ) && $_POST['original_post_status'] == 'auto-draft' ) ||*/ ( defined('DOING_AUTOSAVE') && DOING_AUTOSAVE ) || wp_is_post_revision($id) || isset($_POS T['_inline_edit']) ) { return $id; }

    The “Don’t Tweet/Tweet” option is no longer ignored. Other fields on the form generated by WordPress to Twitter will also stop getting ignored, too.

    I don’t know enough about WordPress to know if this is going to have any nasty side effects. But I haven’t seen any so far in my limited testing. There’s been no spurious tweets out to my feed, for example.

    Can anyone tell me what checking for the auto-draft status is designed to protect against?

    Plugin Author Joe Dolson
    Participant

    @joedolson

    Checking against the auto-draft status is supposed to block a query to the saving of statuses on the initial creation of the auto draft.

    It’s odd, but although your issue makes perfect sense to me, I can’t reproduce it. Nonetheless, this was nothing but a change to increase efficiency, and backing it out is no problem, so I’m just going to do that.

    My problem could be related to the fact that the database I run my server has the settings “auto_increment_increment” and “auto_increment_offset” set to something other than 1. Perhaps this is confusing WP somehow. This is just pure speculation on my part but it’s caused other weird problems for me with other software that erroneously assumes that the next id in the table is one larger than the last.

    Thanks for your help!

    Plugin Author Joe Dolson
    Participant

    @joedolson

    Mmmm…maybe. Can’t think of a reason that it would, but it could be possible. Not a worry. I’ve released the reverted version anyway; it wasn’t a critical change.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Tweet still gets sent with "Don't tweet this post" selected’ is closed to new replies.