WordPress.org

Forums

(Tweet Old Post) Impossible to save changes, kicked out to the login page (19 posts)

  1. amauryb
    Member
    Posted 3 years ago #

    Hi,

    I recently installed the lastest version of Tweet Old Post but I am unable to customize it as I am kicked out of my blog administration page everytime I want to save changes.

    Apparently I am not the only one to experience this problem. I tried to desactivate every othe plugin to save changes but it still don't work.

    Any Idea ?

  2. iagofraga
    Member
    Posted 3 years ago #

    I have exactly the same problem. Downloaded today from wp serching plugin tool and latest version of Wp.

    Thanks if anybody knows. If any data missing just ask.

  3. jeremyers1
    Member
    Posted 3 years ago #

    I am looking for a solution to this as well. I have the plugin on 3 blogs. It works on one of them, but not the other two.

    All three have identical hosting and themes. There are some different plugins and settings on all three, but I have gone through all the options I can think of and have not been able to figure out why it doesn't work on the two when it does work on one of them.

    It is very strange.

  4. jeremyers1
    Member
    Posted 3 years ago #

    By the way, here is a list of plugins that the two websites that cannot run Tweet Old post have in common, which the one website that can run the plugin does not have installed:

    FD Feedburner Plugin by John Watson
    Redirection by John Godley
    Tabber Widget by iThemes
    TentBlogger Simple Top Commenters
    TentBlogger Simple Top Posts
    Weasel's HTML Bios by Andy Moore

    Do either of you have any of these six plugins installed? If so, maybe we have found our culprit.

  5. jeremyers1
    Member
    Posted 3 years ago #

    It is not a plugin causing this in my case. I disabled all plugins, and the Tweet Old Post plugin still doesn't work.

    So now I will start comparing settings between my three sites to see what might be causing this.

  6. scottmliddell
    Member
    Posted 3 years ago #

    I have the same issue on a couple of sites.

    When I try to reauthorise I get kicked back to admin dashboard.

    When I try to make any changes to settings I get kicked back to login page ( so I can't enable logging ).

    Any help very welcome!

  7. jeremyers1
    Member
    Posted 3 years ago #

    Scottmliddell,

    So it works on some sites, and not on others?

  8. scottmliddell
    Member
    Posted 3 years ago #

    Only have it on two sites and both have exactly the same behaviour.

  9. jeremyers1
    Member
    Posted 3 years ago #

    I don't know if it matters, but I found out from my Host today that they have allow_url_include turned OFF, and this sometimes hinders some WordPress plugins and other WordPress automated features. They have it turned off for security reasons.

    Does anyone know if Tweet Old Post requires the use of allow_url_include?

  10. prrichar1
    Member
    Posted 3 years ago #

    any updates on this issue. I have the same problem on some of my web sites. I also had my host admin change the "allow_url_include" and no change. I am using WP 3.3 and Tweet old Post - 3.27

  11. mikemac29
    Member
    Posted 3 years ago #

    I've seen the posts detailing that Google Analytics for WordPress seeems to cause this behavior and that disabling it will allow the plugin to work. However, I don't use that plugin. I have it working on one site, not on another, and I've disabled all plugins unique to the site that doesn't work, so it can't be a plugin conflict in all cases. Anyone else found any other hints?

  12. jeremyers1
    Member
    Posted 3 years ago #

    I think what I am going to do is try some of the older versions, and if I find one that works, look at the code to find out what changed and what might be causing the problem.

    http://wordpress.org/extend/plugins/tweet-old-post/download/

    If anyone gets one of these older versions to work, can you post it here for teh rest of us?

  13. jeremyers1
    Member
    Posted 3 years ago #

    Ok... I'm crossing my fingers, but I think I figured it out.

    I have several blogs. This plugin only works on one of them. The only difference between the various blogs is that they all use the "www" prefix in their URL except for one...the one that runs this plugin.

    In inspecting the code, I discovered that the plugin is using the non-www URL for the plugin. So... I went and edited this file:

    /tweet-old-post/top-admin.php

    and found the following lines of code:

    <h2>' . __('Tweet old post by - ', 'TweetOldPost') . ' <a href="http://www.ajaymatharu.com">Ajay Matharu</a></h2>
    				<form id="top_opt" name="top_TweetOldPost" action="' . top_currentPageURL() . '" method="post">
    					<input type="hidden" name="top_opt_action" value="top_opt_update_settings" />

    and then changed this part:

    action="' . top_currentPageURL() . '"

    to this:

    action="http://www.EXAMPLEURL.com/wp-admin/admin.php?page=TweetOldPost"

    You would, of course, put your actual URL where it says and of course, if you have wordpress installed in a directory like /blog/ or /wordpress/ you would have to add that to the URL.

    It now lets me save changes without dumping me out. Now I will monitor it to see if it actually sends proper tweets.

    I am sure there is probably a way to use a WordPress function to call the proper URL rather than pasting it in this way, but I will try to this for now.

  14. mikemac29
    Member
    Posted 3 years ago #

    Thanks, that actually allows me to save changes, but I'm still getting the redirect to login when I try to authorize with Twitter. I assume this same sort of error is taking place, but in a different place. Anyone know where that function gets called?

  15. amauryb
    Member
    Posted 3 years ago #

    AMAZING. After 3 months of hope Jeremyers1 found the solution. Everything works for me now. Thanks a lot dude.

  16. jeremyers1
    Member
    Posted 3 years ago #

    I am glad it works. It is working for me now too.

    I am not sure what might be holding up mikemac29 still. I am assuming you deleted the plugin and then reinstalled and reactivated it?

  17. mikemac29
    Member
    Posted 3 years ago #

    Actually yes, I have reinstalled the plugin, made the change and still the same result on trying to authorize with twitter.

    Two things I've found, 1) it does seem to be redirecting back to wp-login.php?redirect_to URL/wp-admin/admin.php&pageTweetOldPost*TOP_oauth (Everything appears correct other than the ASCII code replacing / in everything after the wp-login.php) and simply requiring a login again, despite any attempts to stay logged on persistently, and it is not completing the authorization with Twitter.

    2) There is a call to "top_currentPageURL() " in the includes/oauth.php file, but my attempts to replace that with the full path to the page in the same way have only wound up breaking the plugin. (Blank white page)

  18. prrichar1
    Member
    Posted 3 years ago #

    I also made the changes and now I can update the parameters, however I cannot reauthorize access to Twitter, same as some other folks on this message board. anymore ideas??? Thanks to jeremyers1 for getting us this far

  19. John Overall
    Member
    Posted 2 years ago #

    I do believe I have a fix for folks although it may be temp..

    The biggest problem I found was that plugin was trying to rdirect to the wrong url i.e. the www version vs the non www version of url here is where I found the issue..

    in the top-admin.php file on about line 458 look for following code

    <input type="text" style="width:500px" id="top_opt_admin_url" value="' . $admin_url . '" name="top_opt_admin_url" /><br/><b>(Note: If this does not show your current URL in this textbox, copy paste the current URL in this textbox)</b>

    Then where it says value="' . $admin_url . '" change that to your proper url i.e. http://www.mydomain.com/wp-admin/admin.php?page=TweetOldPost

    this solved it for me hope it helps others.

    [ Signature moderated per forum rules. ]

Topic Closed

This topic has been closed to new replies.

About this Topic