Support » Plugin: Tweeple » tweet not updating, unless manual clear cache

Viewing 4 replies - 1 through 4 (of 4 total)
  • Now it is display one from October, and clearing the tweeple cache isnt changing it.
    You can see it here at the bottom of the page:
    http://www.aaionline.org/

    It is on Hostgator.
    FWIW, I have another site on WPengine, and it is working fine there.

    Has there been any resolution on this?

    I am having the same issue and may have to switch themes as my client needs a Twitter feed.

    Plugin Author Jason

    (@themeblvd)

    Tweeple uses an very basic implementation of setting WordPress transients. If your cache isn’t clearing itself, it means there’s some issue with setting WordPress transients on your server setup.

    In all honesty, I’m not totally sure why this happens. I had a customer in my own support forums that I worked closely with that had an issue with this. I had them install this plugin to monitor the issue more closely:

    https://wordpress.org/plugins/transients-manager/

    And what we found was that most of the time the cache would get set properly, but every once in awhile, for who knows why, the WordPress transient expiration was set to 0 — Once this happens, it nulls the transient expiration and that cache never clear itself. At this point, I’m not sure the solution, and I’ve never been able to replicate the issue on any of my own servers.

    Plugin Author Jason

    (@themeblvd)

    I should add that I’ve looked several times at this, and I’m not sure how the Tweeple plugin itself could ever pass 0 when setting the transient.

    But in the last update posted to Tweeple a few days ago, I added a filter that allows you to manually filter the caching time, as it’s getting passed from Tweeple to WordPress’s set_transient().

    https://github.com/themeblvd/Tweeple/blob/master/inc/class-tweeple-feed.php#L270

    So, in theory the following code could be added to your child theme’s functions.php (or your own plugin, or wherever you want), to ensure that the Tweeple plugin is never passing 0, which is what causes the never expiring transient.

    function my_cache_time() {
    	return 7200; // Manually force cache time for all feeds
    }
    add_filter('tweeple_cache_time', 'my_cache_time');

    You can give that a try on your sites and monitor several days, and see if anything changes. If nothing changes, then it suggests a bigger issue with setting WordPress transients in general and your server possibly? And if it does solve your problem, then it could point more towards the issue existing in the Tweeple plugin, itself.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘tweet not updating, unless manual clear cache’ is closed to new replies.