Support » Plugins » Tweet Blender: "No tweets found for"

  • Tweetblender was running great for a week or so but then quit. I had it in two places. The first was in a widget on the main page and the second was on a page. I think I ran afoul of the Twitter API limits so I removed the main page widget. Now the page that has tweets claims not to find any. There are plenty. I deactivated the plugin for a week while I did some other week. Started it up again and still have the same issue. “NO tweets found for…” Nothing in the widgets changed. I tried deleting my cache (those didn’t display either) but that had no effect. Did I shoot myself in the foot again somewhere?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Oh and the server’s API limit was exhausted within 20 minutes. The user API still had about 82 left.

    Exact same issue here.

    I’m using the shortcode in my template, rather than use a widget. I am passing the query with a variable $twittersearch:

    <?php tweet_blender_widget(array(
                 'unique_div_id' => 'single-twitter-widget',
                 'sources' => $singleTwitterQuery,
                 'refresh_rate' => 60,
                 'tweets_num' => 5,
                'view_more_url' => ''.$twittersearch,

    Any help would be appreciated.

    I’m also having the same problem. I just noticed that the tweets had stopped coming in. I hadn’t changed any code (I’m using the same thing as James), but I’m getting the “No Tweets for …” message. I’m using WP 3.1.2 and plugin version 3.3.9 (although I just upgraded — and it wasn’t working with the previous plugin version either).

    I have Tweet Blender on another site where it is working. That site is using plugin version 3.3.5. Maybe something broke in a recent upgrade?

    Also would appreciate any insight on this.


    I tried replacing my 3.3.9 version with an older version… 3.2.4 — still doesn’t work. Maybe it doesn’t work with recent versions of WP?

    I’m thinking it has to do something with the exhausted API limit. My site is hosted at Network Solutions. There may be other sites at the same shared IP using Twitter. Each time a bot tries to read the page the API limit is reached within minutes. Perhaps we need to tell bots not to ,read the page? The other weird thing is that the tweets in the database also stopped appearing on the page. Nothing I was doing seemed to change the situation so I’m just waiting it out.

    @relish1227: explained your situation in this thread – – your tweets are not being indexed by Twitter so search is not working.

    @popwireless: what’s the url of your site? You might have the same issue. Twitter often purges their index and search is very unreliable. Also, are you re-routing things through your server or do you have private accounts that need oAuth? Why is server API exhausted?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Tweet Blender: "No tweets found for"’ is closed to new replies.