Support » Themes and Templates » Tweaking Heatmap , many questions.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Dustyhawk,

    To eliminate sidebars in 404.php just delete:

    <?php get_sidebar(); ?>

    For the search bar. If you want to use the Google Custom Search Feature then that’s built into the template already. You just need to add the code to your HeatMap Options Page:

    Here’s the user guide entry:
    http://heatmaptheme.com/adsense-theme-for-wordpress/version-2/google-adsense-custom-search/

    Make sure you shorten the text field length from 31 to something smaller when setting up your google custom search code so it fits in the template nicely.

    Thanks for the help.

    Now on to my 3rd Question which involves :

    http://www.askapache.com/seo/404-google-wordpress-plugin.html

    Go to my site and simply add /iweow to the back and you will see that the 404 plugin works fine, however i’m trying to do it in such away that it will appear like a result page such as the google-page-template.

    So basically what you need to do is take the code from the google-results.php and whack it into your 404.php, and then include the call required by the plugin.

    I haven’t tried this but here’s where I would start fiddling…

    Replace the main code in your 404.php with this:

    <div id="google-results-body-wrapper">
    
    	<div class="google-search-content">
    		<?php if(function_exists('aa_google_404'))aa_google_404();?>
    	</div> <!-- class="google-search-content" -->
    
    </div> <!-- id="google-results-body-wrapper" -->
    
    <?php get_footer(); ?>

    That should give the 404 plugin results wrapped in the google results style page layout.

    Unfortunately that does not work for me. Currently the coding for the 404.php is as such : http://pastebin.ca/1514529

    More clues required. 😉
    Are you getting an error?
    Is the page just blank?
    Does it do anything at all?
    ta

    it does this : http://gallery.dustyhawk.com/albums/userpics/404heat1.jpg

    as you can see, the 404 plugin does work , but there is that big empty white column on the right and that issue right at the bottom after the footer area.

    The issue with the width of the results within the page is due to the ask apache plugin generating a CSS class with a name that is the same as one in HeatMap Theme – namely the ‘content’ class.

    You can easily change it in the options page for apache 404 in the HTML setup section.

    So where you find <div id=”content”> change it to something else. (say ‘content404’)
    Also there is a width declaration in the same HTML (by default 750px) – I suggest changing it to 950px.

    The issue at the bottom of the page where the results are mysteriously repeated does not appear to be a result of interacting with HeatMap Theme. I tried switching to the WordPress Default theme and the 404 results still appeared there at the bottom of the page even with ‘dafault theme’ activated. They disappeared when I turned the plugin off.

    I suggest checking with the plugins author for help with that issue.

    hey Stuart,

    Thanks!, Gonna check with plugin author now.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Tweaking Heatmap , many questions.’ is closed to new replies.