Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Turning Publicize off throws fatal error on Gutenberg editor

  • Resolved sloweye

    (@sloweye)


    I’m getting this fatal error when I try to edit a post with the Gutenberg editor if Jetpack publicize is turned off. If I turn publicize on or follow the link to the classic editor instead, then no problem. I’m turning just Publicize off and on from ‘/admin.php?page=jetpack_modules’

    ‘Fatal error: Uncaught Error: Call to a member function current_user_can_access_publicize_data() on null in /home/xxxxxxxx/public_html/wp-content/plugins/jetpack/_inc/lib/core-api/wpcom-fields/post-fields-publicize-connections.php:118 Stack trace: #0 /home/xxxxxxxx/public_html/wp-content/plugins/jetpack/_inc/lib/core-api/wpcom-fields/post-fields-publicize-connections.php(136): WPCOM_REST_API_V2_Post_Publicize_Connections_Field->permission_check(3452) #1 /home/xxxxxxxx/public_html/wp-content/plugins/jetpack/_inc/lib/core-api/class-wpcom-rest-field-controller.php(116): WPCOM_REST_API_V2_Post_Publicize_Connections_Field->get_permission_check(Array, Object(WP_REST_Request)) #2 /home/xxxxxxxx/public_html/wp-includes/rest-api/endpoints/class-wp-rest-controller.php(394): WPCOM_REST_API_V2_Field_Controller->get_for_response(Array, ‘jetpack_publici…’, Object(WP_REST_Request), ‘jetpack-portfol…’) #3 /home/xxxxxxxx/public_html/wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php(1579): WP_REST_Controller->add_additio in /home/xxxxxxxx/public_html/wp-content/plugins/jetpack/_inc/lib/core-api/wpcom-fields/post-fields-publicize-connections.php on line 118′

    I’m happy to send the debug report, etc, but for some reason your contact form claims I’m not logged into WP.com though WP.com says I am and is happy to allow this post using that login. Tried a different browser, but no luck with your form.

    • This topic was modified 2 years, 4 months ago by .
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support lizkarkoski

    (@lizkarkoski)

    Hi –

    Thanks for getting in touch. I can email you and collect the report. Are you working on sloweye.net or a different site?

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Sorry for the trouble!

    This is a known issue with Gutenberg and the current version of Jetpack. We’re working on a fix here.

    Until the problem is solved, I can recommend 2 work-arounds:

    1. You can go to Jetpack > Settings > Sharing in your dashboard and enable the feature allowing you to automatically share posts.
    2. You can add the code snippet mentioned here to your site.

    Let us know how it goes!

    Thread Starter sloweye

    (@sloweye)

    Thanks for both responses.

    Yes, this was with the site my profile links to.

    Just tried the snippet, but that doesn’t fix it for me. Problem is only showing up on a few jetpack-portfolio posts that have already been edited with Gutenberg. And only if the Publicize module is deactivated. No problem with the default post-type where Gutenberg is used. Not using Gutenberg w/ Woocommerce products yet, so can’t test that.

    I tried editing the snippet to ‘remove_post_type_support( ‘jetpack-portfolio’, ‘publicize’ );’ instead of woocommerce, but no luck.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Thanks for the additional info. In this case I would recommend enabling the Publicize module for now. You can still use the snippet I mentioned (while replacing it with jetpack-portfolio, as you mentioned), so Publicize does not get triggered when you publish new Portfolio projects.

    Thread Starter sloweye

    (@sloweye)

    Ok, understood. Thanks for the tip about avoiding triggering Publicize, will put the snippet back in and wait for the fix.

    Plugin Support lizkarkoski

    (@lizkarkoski)

    @sloweye

    Let us know if you have any trouble getting that sorted 🙂

    You can also follow along at https://github.com/Automattic/jetpack/pull/10745

    I’m also getting a similar error (not using Gutenberg editor). That error is preventing my Ship Easy integration from functioning (can’t pick up orders from our site). Enable publicize “fixes” it?

    2018-12-01T17:32:00+00:00 CRITICAL Uncaught Error: Call to a member function current_user_can_access_publicize_data() on null in */wp-content/plugins/jetpack/_inc/lib/core-api/wpcom-fields/post-fields-publicize-connections.php:118
    Stack trace:
    #0 */wp-content/plugins/jetpack/_inc/lib/core-api/wpcom-fields/post-fields-publicize-connections.php(136): WPCOM_REST_API_V2_Post_Publicize_Connections_Field->permission_check(18798)
    #1 */wp-content/plugins/jetpack/_inc/lib/core-api/class-wpcom-rest-field-controller.php(116): WPCOM_REST_API_V2_Post_Publicize_Connections_Field->get_permission_check(Array, Object(WP_REST_Request))
    #2 */wp-includes/rest-api/endpoints/class-wp-rest-controller.php(394): WPCOM_REST_API_V2_Field_Controller->get_for_response(Array, 'jetpack_publici...', Object(WP_REST_Request), 'product')
    #3 */wp-content/plugins/woocommerce/includes/api/v2/class-wc-rest-products-v2-c in */wp-content/plugins/jetpack/_inc/lib/core-api/wpcom-fields/post-fields-publicize-connections.php on line 118
    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Turning Publicize off throws fatal error on Gutenberg editor’ is closed to new replies.