Support » Fixing WordPress » Turning off the auto save

  • How can i turn off the auto save i have gone into my plugins and turn it off there. For some reason how it will still save my files. When i hit the publish tab after my blog has been written i get an error that says “are you sure you want to edit this post: “”? yes or no. What ever i click it just looses the post.

    Any ideas would help. I did search for the problem and found something related and did as the post said. Still no luck.

    anything would help at this point.

    thanks all

Viewing 15 replies - 1 through 15 (of 35 total)
  • PLEASE WOULD SOMEONE AT WORDPRESS ANSWER THIS?

    This feature sucks and I really want to turn it off. All it does is create duplicate posts.

    it appears that there is a bug (#3379) related to autosave, clicks in the edit page, though that was posted 3 months ago and v2.1.1 is newer than that.

    Does anyone know how to incorporate the changes from a “diff” file (should change wp-includes/js/autosave.js.php) so I can fix this? It basically makes categories not usable.

    I just opened that autosave.js.php file and changed the delay value (1000) to 3000 and it appeared to fix things.

    well, crapola. that didn’t fix the issue. It appears that duplication is being caused by adding custom fields, not autosaving? Every time I add a custom field, it asks “Are you sure you want to edit this post?” (no, yes) and on clicking yes, it adds a duplicate post.

    this just sucks.

    OK. maybe there’s a workaround and maybe this is a bug? If you click NO on the “are you sure” screen, it edits the post anyway (NICE, folks… what was whomever created that smoking?) Can you say “good interface design – NOT!”

    So, I am able to click Save and continue editing, then No for the “are you sure” screen and get the edits done… now, just how to explain to the client why the method is so ***k** up in the first place…

    There is serious stuff going on in v2.1.1

    Posts are being marked private.
    Custom fields can’t remember what post they belong to (they show up for Write>Post – new post)
    Sometimes the default category is marked under Category, sometimes not. When not, private gets set.

    PLEASE someone at WP fix these things!

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Add this to your theme’s functions.php file:

    <?php
    function adjust_autosave($seconds) {
    return "999999";
    }
    add_filter('autosave_interval','adjust_autosave');
    ?>

    Autosave isn’t “off” this way, but it might as well be. 🙂

    Well, I realize now that the problem isn’t auto save. It’s the stupid Are you sure you want to edit this page: “”? screen that you get when you add a custom field, then click save and continue editing or even save.

    CLICK NO. (I know, it’s counter-intuitive, but that’s the issue)

    I suspect it has something to do with the fact that the page isn’t listed in the quotes

    Are you sure you want to edit this page: “”?

    it doesn’t KNOW WHICH PAGE.

    Click NO. That simply avoids the whole issue, though I am going to go in and edit page.php (admin) to figure it out as soon as I have time. Something’s screwy in there.

    another note: if you use Save and continue editing after adding a custom field, it WILL NOT save changes made to the right column’s options (like comment options, etc)… You have to use the save button to get those to stick.

    Frankly, I am confounded by this new functionality “are you sure”… what purpose does it server except to add extra steps to the workflow? You have to click Save and continue editing after each custom field add… (which is also stupid, imo) so now it takes 3-4 clicks to do one custom field.

    moronic.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    If you’re getting those boxes, then it’s likely that:
    a) Your browser is caching the wrong javascript, or
    b) You have some incorrect version of the scriptaculous javascript on your server interfering with the built-in one in some way, or
    c) You have failed to update all the files when upgrading to the latest version.

    Or some combination of those. Also, ad-blockers and privacy blockers and even some wordpress plugins can interfere.

    In short, what you’re describing is an error in your setup somehow, not actual intended behavior. I don’t get that happening to my site, for example.

    1) this was an official fantastico install (clean) where previous installs didn’t do it
    2) only updated the theme files and plugins, and db, of course… simple plugins, too… all of which worked with v2. I’ve tried disabling all plugins and it fixes nothing…

    here’s my list of plugins:

    witty.txt (I’ve tried deactivating these and it doesn’t fix anything)
    Get Custom Field Values (which is working)
    Dagon Design Form Mailer ( just did this one – issue was happening BEFORE activating this)

    and other folks are having the same problems, so I believe this IS a bug with the new version, relating to custom fields

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    this was an official fantastico install

    I do not trust automated installations of WordPress. My advice: Install it yourself, manually.

    I believe this IS a bug with the new version, relating to custom fields

    Other people are not getting the same symptoms as you are. I cannot even reproduce the behavior you are describing. This points very heavily towards it not being an actual bug with the software, but a problem with your particular installation or configuration or setup or browser or *something*.

    It’s be nice to know if anyone has a fix for this – still a major problem in 2.1.2 🙁

    It’s a manual install, Firefox 2.0, standard set-up.

    Open up write > pop in something > wait until it auto-saves > press publish > this problem

    For the record, I got this while leaving an editing window (for a page) open overnight. I just tried saving it again without leaving it untouched for so long and it was fine.

    Get Custom Field Values (which is working)

    I believe I had to tweak something in this plugin to cure the difficulty… every now and then I get the infuriating “Are you sure?” page of DOOM but it happens infrequently now.

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘Turning off the auto save’ is closed to new replies.