Support » Theme: Hueman » Turning off soclal links

  • I want to turn off social links altogether in one site, and move them to a better location (to the topbar, not the sidebar).

    1) There is a function in sidebar.php “hu_has_social_links()” which leads me to believe there is a setter for this, but I cannot find it.

    2) If I want to move the entire social links bar do the header, do I move all this code from the sidebar, or is there an easier way?

    <?php if ( hu_has_social_links() ) : ?>
    <p><?php _e(‘Follow:’,’hueman’); ?></p>
    <?php else : //if not customizing, display an empty p for design purposes ?>
    <?php if ( hu_user_can_see_customize_notices_on_front() ) : ?>
    <?php
    printf( ‘<p style=”text-transform:none;font-size: 0.8em;”>%1$s. %3$s »</p>’,
    __(‘You can set your social links here from the live customizer’, ‘hueman’),
    admin_url( ‘customize.php?autofocus[section]=social_links_sec’ ),
    __(‘Customize now’, ‘hueman’)
    );
    ?>
    <?php elseif ( ! is_user_logged_in() ) : ?>
    <?php printf(‘<p> </p>’); ?>
    <?php endif; ?>
    <?php endif; ?>

    <?php hu_print_social_links() ; ?>
    </div>
    <?php endif; ?>

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter shoqvalue

    (@shoqvalue)

    “You can set your social links here from the live customizer. Customize now »”

    The message above pollutes my interface and you give me no obvious way to turn it off? It’s very annoying to have to waste time finding out how to do things that should be intuitive.

    Thread Starter shoqvalue

    (@shoqvalue)

    I realize end users don’t see that message, but I don’t want to see it either as an admin. How the heck do I get rid of it?

    Hi there,
    you could override the sidebar.php in your child-theme and alter the code that prints out that message.

    Anyway I filed an issue on the theme issues tracker about considering adding an option to not display help-blocks/notices in front.

    Best.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Turning off soclal links’ is closed to new replies.