Support » Fixing WordPress » Turning off self-registering

  • Resolved beiffert

    (@beiffert)


    I just had a new user self- register on my blog. I got email notification of it happening. User Level was 9!

    I don’t want other users on this blog, I don’t require reg. for comments. Person didn’t post anything, but didn’t set a password either.

    Is there a way to turn off the self reg feature?

    Running 1.5.1 when that happened (today), now running 1.5.1.2

Viewing 4 replies - 1 through 4 (of 4 total)
  • Mark (podz)

    (@podz)

    Support Maven

    Delete the file ‘wp-register.php’

    Were they really at level 9 ??

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    And, make sure that the allow registration option is unchecked in Options/General.

    And delete the register link.

    Thanks! I didn’t have a register link on site (beiffert.net), so I guess person just knew what file to open to register.

    I can’t believe I didn’t see the registration option checkbox before, I had unchecked the ‘user must be registered to comment’ box….. Both are unchecked now!

    I didn’t try to go in as the new user, but it took 9 clicks on – level to get to 0 to delete.

    I’ve now deleted the wp-register.php file. Don’t know how much that is from paranoia, but it sounds like a good extra safety measure.

    Thanks to all three of you for the rapid and on-target responses!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Turning off self-registering’ is closed to new replies.