WordPress.org

Forums

[resolved] Turning Off Comments & Replies (4 posts)

  1. acidtax
    Member
    Posted 1 year ago #

    I am going to ask a question that, based on my searches, has been asked repeatedly in the past; unfortunately, the solution that accompanies all of those previous posts does not work. To wit: going to Settings --> Discussion and unchecking the tick box beside "Allow people to post comments on new articles" does nothing whatsoever. The leave a comment/leave a reply box stays firmly planted at the bottom of the page.

    I have come across the Disable Comments plug-in that, according to its description, will do this. However, I do not like blackbox solutions and would like to know how comments/replies are in fact turned off. If I have to, I will simply hack the php code and excise the function manually, but it seems rather a shame to have to do something like that.

    If my tone offends, I apologize; like so many of the folks who've posted this question in the past, I've spent several hours trying to get this accomplished, to no avail.

  2. However, I do not like blackbox solutions and would like to know how comments/replies are in fact turned off.

    When you create/edit a post/page... there is a box under the content editor titled "Discussion".

    If you do not see this box.. scroll to the top of the create/edit post/page screen.. and look at the top-right corner for a box labeled "Screen Options".

    Click that tab, and it will slide down, displaying more advance options for the create/edit post/page screens.

    Make sure the checkbox for "Discussion" is checked.

    Now, scroll down the page (below the content editor), and you should see the box titled "Discussion".

    In that box, you will see the options for disabling comments and trackbacks for that specific post/page.

  3. acidtax
    Member
    Posted 1 year ago #

    Josh,

    Thanks for the help. I followed your steps and not only did I find how to turn off comments/replies for a particular page while it's being edited, I discovered that comments/replies can be turned off for all existing pages.

    I accomplished this by going to Pages --> All Pages, checking the box for every page, and then using the "Edit" bulk action in the drop-down menu. Doing that opens up an option set consisting of 5 drop-down menus: Author, Parent, Template, Comments, and Status. The "Comments" drop-down menu has the option to "Do not allow" which, when selected, turns off the comments to every page the bulk action was done on. (note: there are other options in the option set, but I didn't want to list all of them lest I make my post more confusing than necessary).

    Similarly for posts, I went to Posts --> All Posts, checked the boxes for the existing posts, and applied the "Edit" bulk action to them. That brings up an option set that has the following drop-down menus: Author, Comments, Status, Format, Pings, and Sticky. The "Comments" menu has the option "Do not allow" which, when selected, turns off the comments to every post the bulk action was done on.

    Again, I really do appreciate your time and help, especially since you made it possible for me to discover more or less the function I was looking for: turning off comments/replies on all pages and posts.

    I just want to add one little comment to the WP developers: this functionality really needs to be put in either the general settings tab or on the main "Pages" and "Posts" pages, respectively. It should be clear and obvious and users - especially new users - should not have to go hunting for it. I say this because, candidly, after several fruitless hours last night I was ready to nuke the entire WordPress installation and try out another CMS.

  4. My pleasure.

    Never be afraid to get a cup of coffee, and sit down with the WordPress Codex.

    It is a community driven collection of resources, examples, descriptions, illustrations, and other useful information.

    Thank you also for the additional information in your comment above.

Topic Closed

This topic has been closed to new replies.

About this Topic