Turning off comments (6 posts)

  1. Jon12345
    Posted 8 years ago #

    I seem to be inundated with spam comments at the moment. Is it possible to turn off the ability of someone to submit comments to my blog?



  2. Jon12345
    Posted 8 years ago #

    Please note that I have just upgraded to 2.1 and I am still getting these spam comments. I just want to turn the comment feature off. How?

  3. Samuel B
    Posted 8 years ago #

    admin -> Options
    check users must be registered and logged in to comment

    This won't stop your problem. You're likely getting trackback spam.
    Install Bad Behavior (google for it) along with Akismet or Spam Karma2.
    This will stop that junk cold.

  4. Jeremy Clark
    Posted 8 years ago #

    Yes in the dashboard under the options tab, then under Discussion there are two options that you can uncheck

    • Allow link notifications from other Weblogs (pingbacks and trackbacks.)
    • Allow people to post comments on the article.

    This will disable commenting and pinging.
    There are a few plugins that would also help ease the strain of spam and still allow commenting. One is Askimet which is included in every wordpress installation. Just go to the plugins page activate it and follow the instructions here. Another great plugin is Bad Behavior

  5. Jon12345
    Posted 8 years ago #

    I have unchecked the two options you mention, but I am still getting spam comments. Why is that? Seems odd since I have unchecked these items.

  6. Chris_K
    Posted 8 years ago #

    Please re-read samboll's first post to you. The key is that these are trackbacks, not comments.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.