Support » Fixing WordPress » Turning OFF “Automatically close comments on articles older than”

  • kevintroyan

    (@kevintroyan)


    Under the discussion settings, there is a box under the section “Other Comment Settings” labeled “Automatically close comments on articles older than”.

    I keep ticking the box so there is NO check mark. I want to have comments enabled for all of my posts.

    However, after a week or so it automatically gets checked and no one can leave a comment.

    I have even tried setting the days to a very high number but it still keeps getting reset to 28 days and the box being checked.

    How do I make it so this box if unchecked at all times?

    Thank you

Viewing 11 replies - 1 through 11 (of 11 total)
  • Same here. I’ve had this for over a year. I’ve resorted to checking my Discussion settings every. single. day. to check if the box is still off or has mysteriously marked itself “on”. Would love to have a solution to this.

    I have the same problem. I also check my Discussion settings every day. WORDPRESS please help us.

    Same here!

    No solution offered??? Hey, community, any advice?

    Can anyone with this problem please tell me what host you are using?

    BLUEHOST in my case.

    I’ve had to manually uncheck the “automatically close comments” option twice since Christmas.

    • This reply was modified 1 month, 2 weeks ago by  barryemma.

    Ahhh.. of the 2 folks I’ve talked to and the one post I saw on another site, all Bluehost folks. coincidence? If you do write their support @barryemma please let me know if they have any comment on this issue.

    I’m with Hostmonster, but I’m sure it’s not a host issue. I have my own versions of WordPress there, which I maintain. The comment box issue is currently resolved for me… unfortunately I don’t know what fixed it. I tried a variety of people’s simple suggestions, but I was traveling (between flights) at the time and I don’t know what I did. Possibly just switching comments off then on again. I hope it stays fixed. Good luck to the rest of you!

    well… Bluehost is a “sister” company of hostmonster, so I will not cross that off yet 😉
    Thanks for the input!

    jontotheworld12345

    (@jontotheworld12345)

    Hi Kim,

    Mine is also BLUEHOST. Please help us.

    Regards,
    Jon

    @jontotheworld12345 I tried to ask a BlueHost Chat person about it but without an account affected by the issue, I could not get far.

    It would be helpful if someone with the issue contacted BlueHost support and let them look at your setups. Perhaps we can at least find out if they are doing something to make this happen on their end.

    Please do post here if you find out something new.

    Depending on how OLD or NEW your account is… Blue Host has their own “My Site” page (it looks similar to WordPress.com.

    On that page are some of the settings from the WordPress Admin… one is a Comments box with the fields we have talked about.

    https://www.dropbox.com/s/ksvj7plqmiz1cg6/bluehost.png?dl=0

    Please let me know if this helps.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.