Support » Plugin: Enable jQuery Migrate Helper » Turn off weekly email notifications

  • Hi there.. may I know if it’s possible to turn off the weekly email notification of this plugin? thank you in advance! 🙂

    • This topic was modified 2 months, 2 weeks ago by tiniewini. Reason: update the NSFW
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Marius L. J.



    It is not (unless you use some other plugin for managing what emails can be sent).

    This is an intended feature, as the plugin is only a temporary solution to the underlying problem of outdated plugins or themes, as such we find it important to keep site administrators informed of what is happening to their site, and encouraging them to address issues.

    Once the issues are resolved, this plugin can then be removed, which would stop the emails 😉 (we love to help users, but we love more to see them remove this plugin as it means they’ve gotten an updated set of code for their site).

    I was searching for the same – I really have to turn these off.

    I checked the code, and it’s a hooked action:

    add_action( 'enable_jquery_migrate_helper_notification', array( __CLASS__, 'scheduled_event_handler' ) );

    and a scheduled event:

    wp_schedule_event( time() + DAY_IN_SECONDS, 'weekly', 'enable_jquery_migrate_helper_notification' );

    you can remove these in your child themes functions.php with this code:

    add_action('init', function() {
    	$timestamp = wp_next_scheduled( 'enable_jquery_migrate_helper_notification' );
    	wp_unschedule_event($timestamp, 'enable_jquery_migrate_helper_notification');
    }, 100); 


    This is also a problem for us. We are temporarily dealing with an outdated plugin.
    I understand why you send weekly messages to push admins to come up with a solution. But our customers email is used as the main admin email. He was not happy with this email in his inbox.

    Could you give us an option to manually change the email which the weekly report gets send to?

    • This reply was modified 2 months, 1 week ago by webstijl.

    return wp_mail( $recipient, $title, $message );

    it’s not filtering the recipient anymore. You will have to filter wp_mail (for the subject f.e.) to redirect the mail. This comment in documentation shows you how:

    Please add an option to disable the weekly notification email!

    See my comment on it’s just four lines of code 🙂

    For Pete’s sake, please make it an option within the settings to disable the emails.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.