Support » Plugins » Turn off the autosave already!!!

  • I have been working with WordPress for sometime now and I’ve been reading a lot about how the autosave is such a pain in the a** when writing and editing, and it is! It autosaves every 3 seconds and jumps up to the top of the age we have to scroll back down to look for where we left off, this is a very annoying waste of time.

    I’ve tried the plugin wp cms post control – doesn’t work.

    I’ve tried what’s on http://wordpress.org/support/topic/295244?replies=10 – doesn’t work.

    I’ve tried what’s on http://www.untwistedvortex.com/2008/06/27/adjust-wordpress-autosave-or-disable-it-completely/ – doesn’t work.

    I’m fed up, what does work already?! I see a lot of other solutions, but I’ve lost patients already, I was hoping someone had some insight on this problem and has found what really works.

    Sorry gang, I’m venting. Don’t mean to come across as a jerk, but really, when will WP have this as a setting under ‘writing’ anyway?

Viewing 3 replies - 16 through 18 (of 18 total)
  • Hi christernyc,

    I have the same problem as you, and it is literally driving me crazy. When editing in “html”, text keeps jumping to the top every few seconds wich makes your job a missery, as you have to scroll down and look for the text all the time. I cant belive wp has introduce this diabolic feature by default.

    Will you please let me know in case you find the way to solve this problem. Thanks

    Juan

    I need help as well! the fact is I dont even no what editor to look into. I don’t have a edior labeled “wp-config.php” so do I just go to my “single.php” file instead? and if so what do I do to make it stop because this is getting really frustrating.

    Her is what I am working with in my single.php file.

    <?php get_header(); ?>

    <div id=”leftandright”>
    <div id=”leftcontent”>

    <div class=”oneblog_top”></div>
    <div class=”single_post”>

    <?php if (have_posts()) : ?>
    <?php while (have_posts()) : the_post(); ?>

    <div class=”thetitle”>
    <h1><?php the_title(); ?></h1></div>

    <?php
    $crossblock_postimage_disable = get_option(‘crossblock_postimage_disable’);

    if ($crossblock_postimage_disable != ‘true’) {
    $rs_image_key = ‘image’;
    $thereisimage = get_post_meta($post->ID, $rs_image_key, true);
    if($thereisimage) {
    ?>
    <div class=”post_image”>
    <img alt=”Post image of <?php the_title(); ?>” title=”<?php the_title(); ?>” src=”<?php echo $thereisimage; ?>” />
    </div>
    <?php
    }
    }
    ?>

    <div class=”post_details”>
    <span class=”left”>Filed in <?php the_category(‘ , ‘) ?></span>
    <span class=”right”><?php echo $post->comment_count; ?> comments</span>
    <div class=”clear”></div>
    </div>

    <div class=”the_content”>
    <?php the_content(); ?>
    </div><!–/the_content–>

    <?php wp_link_pages(‘before=<div id=”multipage-links”>Pages : &after=</div>’); ?>

    <div class=”after_post_details”>
    <span class=”left”>Posted by <?php the_author(); ?>   @   <?php the_time(‘j F Y’) ?></span>
    <span class=”right”><?php echo $post->comment_count; ?> comments</span>
    <div class=”clear”></div>
    <span class=”left”><?php the_tags(‘Tags : ‘, ‘ , ‘, ”); ?></span>
    <span class=”right adminedit”><?php edit_post_link(‘Edit This Post’,”,”); ?></span>
    <div class=”clear”></div>
    </div>

    <?php
    $zenverse_global_adsense_id = get_option(‘zenverse_global_adsense_id’);
    $crossblock_adsense_afterpost_enable = get_option(‘crossblock_adsense_afterpost_enable’);
    if ($zenverse_global_adsense_id && $crossblock_adsense_afterpost_enable == ‘true’){
    ?>
    <div class=”adsense-afterpost”>
    <script type=”text/javascript”>
    //<![CDATA[
    google_ad_client = “pub-<?php echo $zenverse_global_adsense_id; ?>”;
    google_ad_width = 468;
    google_ad_height = 60;
    google_ad_format = “468x60_as”;
    google_ad_type = “text”;
    google_ad_channel = “”;
    google_color_border = “f5f5f5”;
    google_color_bg = “f5f5f5”;
    google_color_link = “555555”;
    google_color_text = “555555”;
    google_color_url = “444444”;
    google_ui_features = “rc:0”;
    //]]>
    </script>
    <script type=”text/javascript” src=”http://pagead2.googlesyndication.com/pagead/show_ads.js”></script&gt;
    </div>
    <?php } ?>

    <?php
    $crossblock_socialbookmark_disable = get_option(‘crossblock_socialbookmark_disable’);
    if ($crossblock_socialbookmark_disable != ‘true’) {
    ?>
    <div class=”blogsep”></div>
    <div class=”extra_content”>
    <h3>Share This Post</h3>
    <div class=”socialbmark”>

    “><img src=”<?php bloginfo(‘template_url’);?>/images/sb_rss.gif” alt=”RSS” />
    “><img src=”<?php bloginfo(‘template_url’);?>/images/sb_digg.gif” alt=”Digg” />
    “><img src=”<?php bloginfo(‘template_url’);?>/images/sb_twitter.gif” alt=”Twitter” />
    “><img src=”<?php bloginfo(‘template_url’);?>/images/sb_su.gif” alt=”StumbleUpon” />
    “><img src=”<?php bloginfo(‘template_url’);?>/images/sb_del.gif” alt=”Delicious” />
    “><img src=”<?php bloginfo(‘template_url’);?>/images/sb_techno.gif” alt=”Technorati” />
    </div>
    </div>
    <?php
    }
    ?>

    <?php
    $crossblock_relatedpost_disable = get_option(‘crossblock_relatedpost_disable’);
    if ($crossblock_relatedpost_disable != ‘true’) {
    if (function_exists(‘crossblock_get_related_posts’)) {
    echo crossblock_get_related_posts();
    }
    }
    ?>

    <div class=”blogsep”></div>
    <div class=”extra_content”>
    <h3 class=”left”><?php echo $post->comment_count; ?> People Putting Up Their Middle Finger</h3>
    <?php if ( comments_open() ) : ?>
    <div class=”replyjump”></div>
    <?php endif; ?>
    <div class=”clear”></div>
    </div>

    <?php comments_template();?>

    </div><!–/single_post–>
    <div class=”oneblog_btm”></div>

    <?php
    endwhile;
    ?>

    <div class=”sep”></div>

    <div class=”below-post”>
    <span class=”go-left” style=”width:280px;”>
    <span class=”bold”>Previous Post</span>
    <?php previous_post_link(‘« %link’) ?>
    </span>
    <span class=”go-right align-right” style=”width:280px;”>
    <span class=”bold”>Next Post</span>
    <?php next_post_link(‘ %link »’) ?>
    </span>
    <div class=”clear”></div>
    </div>

    <?php
    else :
    ?>

    <div class=”oneblog_top”></div>
    <div class=”single_post”>
    <h2>Not Found</h2>
    <p>Sorry, but you are looking for something that isn’t here.</p>
    </div><!–/single_post–>
    <div class=”oneblog_btm”></div>

    <?php
    endif;
    ?>

    </div><!–/leftcontent–>

    <?php get_sidebar(); ?>
    <div class=”clear”></div>
    </div><!–/leftandright–>
    <?php get_footer(); ?>

    if ( $key == ‘autosave’ && $value == ‘off’ ) {
    //wp_deregister_script//(‘autosave’);
    }

    Dunno if this will fix your problem, but turning on Compatability View in IE 8 solved this problem for me. Found a post about it here — http://www.mydigitallife.info/2010/04/10/wordpress-editor-jumps-up-to-top-or-beginning-of-text-in-ie8/ — and gave it a shot; worked immediately, which was fortunate for the continuing health of my laptop.

    If you’re not using IE8, never mind 🙂

Viewing 3 replies - 16 through 18 (of 18 total)
  • The topic ‘Turn off the autosave already!!!’ is closed to new replies.