Support » Plugin: All in One SEO Pack » Turn off Schema.org markup

  • Resolved dinoframe

    (@dinoframe)


    After turning off “Use Schema.org Markup” option in plugin settings, I still this code on the home page:
    <script type=”application/ld+json”>{“@context”:”http://schema.org”,”@type”:”Organization”…

    After disabling this plugin the code is gone.

    Expected behaviour is when I turn off “Use Schema.org Markup” option, no JSON LD code is added to the website.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor arnaudbroes

    (@arnaudbroes)

    I doubt that’s coming from us since we’ve removed our Schema.org markup in an earlier release. The option should still be there, but it only adds a single attribute to your starting HTML tag:

    prefix="og: http://ogp.me/ns#" class="no-js" lang="en"

    Check if you’re using the latest version of the plugin and then report back here.

    sanostec

    (@sanostec)

    Arnaud – we have AIOSEO Pack Pro installed v 2.11.1. It contains an option under general setting for Use Schema.or Markup. What do you mean that you have removed your Schema.org markup in an earlier release? What is the purpose of the Schema option in the General Settings?

    Plugin Contributor arnaudbroes

    (@arnaudbroes)

    @sanostec we will be bringing it back once we’ve added support for the new JSON+LD markup. This is why we haven’t removed that setting completely.

    @arnaudbroes is the schema.org markup unavailable?

    Plugin Contributor arnaudbroes

    (@arnaudbroes)

    @renecum we’ve had some basic Schema.org markup in the past, but now we’re working on full support for structured data. We’re launching our next major 3.0 version soon and Schema.org will hopefully be ready when 3.1 comes around.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.