Support » Plugin: All in One SEO Pack » Turn off Schema.org markup

  • Resolved dinoframe

    (@dinoframe)


    After turning off “Use Schema.org Markup” option in plugin settings, I still this code on the home page:
    <script type=”application/ld+json”>{“@context”:”http://schema.org&#8221;,”@type”:”Organization”…

    After disabling this plugin the code is gone.

    Expected behaviour is when I turn off “Use Schema.org Markup” option, no JSON LD code is added to the website.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor arnaudbroes

    (@arnaudbroes)

    I doubt that’s coming from us since we’ve removed our Schema.org markup in an earlier release. The option should still be there, but it only adds a single attribute to your starting HTML tag:

    prefix="og: http://ogp.me/ns#" class="no-js" lang="en"

    Check if you’re using the latest version of the plugin and then report back here.

    Arnaud – we have AIOSEO Pack Pro installed v 2.11.1. It contains an option under general setting for Use Schema.or Markup. What do you mean that you have removed your Schema.org markup in an earlier release? What is the purpose of the Schema option in the General Settings?

    Plugin Contributor arnaudbroes

    (@arnaudbroes)

    @sanostec we will be bringing it back once we’ve added support for the new JSON+LD markup. This is why we haven’t removed that setting completely.

    @arnaudbroes is the schema.org markup unavailable?

    Plugin Contributor arnaudbroes

    (@arnaudbroes)

    @renecum we’ve had some basic Schema.org markup in the past, but now we’re working on full support for structured data. We’re launching our next major 3.0 version soon and Schema.org will hopefully be ready when 3.1 comes around.

    I am seeing the same issue as @dinoframe, i.e. the code with the schema.org does not disappear even after disabling it in the plugin.
    @arnaudbroes, if that was resolved, please share the details, because it screws up the google crawling.

    • This reply was modified 1 month, 2 weeks ago by folloyu.
    Plugin Contributor arnaudbroes

    (@arnaudbroes)

    @folloyu update to the latest version of the plugin.

    @arnaudbroes I am using Version 3.2.10
    If this is not the latest, can you send me the link to the latest please?

    Plugin Contributor arnaudbroes

    (@arnaudbroes)

    @folloyu I’ve just confirmed that this is no longer the case in our latest version (which is v3.2.10) so I’d suggest that you try and narrow the issue down to see if this markup is coming from AIOSEOP, your theme or another plugin.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.