Support » Plugin: Ajax Search Lite » Turn off on mobile

  • Hi
    Been playing with this plugin and I think its great but Im having trouble on mobile. I cant scroll the results, the drop down always closes when I try.
    So is it possible to turn this off on mobile and have it act like a normal search box? if not, I’ll have to remove it as I have a lot of phone users.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author wpdreams



    Thank you for your kind words!

    First, I would suggest turning off the custom scrollbar script, it may be conflicting with something else. You can do that on the Compatibility Settings submenu:

    There is no option to turn off the plugin on a mobile device unfortunately. The only way would be to hide the box completely with custom CSS, but I’m not sure if that would help your case.

    Thanks for the response, its the same issue though.
    When clicking in a text box on mobile the keyboard opens up, taking up half the screen. The ajax drop box appears behind the keyboard so I cant see it. If close the keyboard the input box loses focus and so the ajax results disappear. If I fiddle with it sometimes I can get the keyboard closed and the ajax still open, which is fine unless I miss click then the menu closes again.

    Overall its a big usability problem on mobile. Its great on a PC through, I really like it. But sadly I cant use it if it doesnt work on mobile. Will play with it some more and see if I can get it working consistently.

    • This reply was modified 2 years, 1 month ago by webfeat.

    I also have the same issue, so please if you find anything that helps please write here!


    Plugin Author wpdreams



    If close the keyboard the input box loses focus and so the ajax results disappear

    That should not happen at all. I have tried a few mobile devices, including iPhone, iPad and android 6, 7 phones but the input field does not blur. I suspect this is either a device behavior thing, or more likely a script that somehow detects a screen size change or virtual keyboard behavior in some way, and blurs focus from input fields.

    Can you please try the demo site, and let me know if you see that behavior there as well:

    If so, then please let me know what device (and browser) are you using for testing, I will try to emulate it somehow, if I can’t get a hold of it.

    In earlier versions of the plugin there was a solution that would try to hide the virtual keyboard whenever the results list appeared, however apple decided to remove the control of the virtual keyboard event support, and the android market sort of adapted to it. Still, at this point there is no working cross-device solution to this issue.
    Instead, search engines no longer interact with the keyboard state, and let the user close it as it fits.

    However it should still not lose focus on closing the keyboard, that is not intended.

    I’m sorry i didn’t explain myself right: i don’t lose focus on mobile, its just that sometimes i can’t see the results or can’t scroll them because when i push them up i can see them, but they immediately go down the screen again.

    I think it has to do with my theme, the excellent Customizr. I’m replacing theme search with Ajax Search Lite, and the search stays on the menu bar. On mobile the menu bar is reduced to the hamburger menu and the search field is the last thing i can see… so i think you can understand the issues 😉

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Turn off on mobile’ is closed to new replies.