WordPress.org

Forums

W3 Total Cache
Turn off js minification for NRelate on Multisite (4 posts)

  1. nickhempsey
    Member
    Posted 9 months ago #

    In order to get nRelate to work properly I have to tell W3TC to ignore minification of the nRelate JS. This works fine on the main domain, however, it still minifies for all of the sub sites thus breaking nRelate.

    I have included each of the subsite urls in the ignore block, but it's not working. I've even tried forcing in the nrelate js in the footer, but it replaces that script with the minified version.

    Is there a way around this?

    Thanks.

    https://wordpress.org/plugins/w3-total-cache/

  2. katrina@nrelate
    nrelate Support Rep
    Posted 9 months ago #

    @nickhempsey -- We're trouble shooting the issue for you regarding W3TC and multisites and will keep you updated with what we find.

    - Katrina @ nRelate

  3. katrina@nrelate
    nrelate Support Rep
    Posted 9 months ago #

    @nickhempsey -- Can you please verify that you went into each domain and added these rules?

    - Katrina @ nRelate

  4. nickhempsey
    Member
    Posted 7 months ago #

    Sorry for the late response, I had notifications turned off or this post for some reason.

    W3 Total Cache doesn't have an option to set those rules on each domain, you can only set them on the main domain. I disabled minification temporarily to get nRelate back up and running, but now a new issue has arisen. If you look at the French version, it shows two instances of nRelate, whereas each of the other subdomains only shows once.

    French: http://sexyfitness.com/fr/abdos-en-tablette-crunch-bras-tendus/

    Spanish: http://sexyfitness.com/es/encogimientos-abdominales-brazos-extendidos/

Reply

You must log in to post.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic