[resolved] Turn off comments (6 posts)

  1. 724shelties
    Posted 5 years ago #

    I am trying to get set up and cannot turn off comments altogether. I see the Settings > Discussion choices but no matter what I do the "Leave a Comment" or the comment form still appears on posts. Right now, I don't want to accept comments; I will later, but not right now.

    I'm currently using the zBench theme on 3.1.3 (just downloaded today).

    I've also looked and the "discussions" box is unchecked on the post, but the comment form still shows up.

    Any ideas? I'd rather not hack code but I can.

  2. alanchrishughes
    Posted 5 years ago #

    I just downloaded the theme and unchecked both the "Allow comments" and
    "Allow trackbacks and pingbacks on this page" options and it removed the form.

    If that definitely doesn't work for you for some reason and you feel comfortable editing your theme files, open the single.php file and look for something that says

    <?php comments_template( '', true ); ?>

    and remove that. It is the forth line from the bottom.

  3. 724shelties
    Posted 5 years ago #

    Thanks for the quick reply alanchrishughes.

    Where is "Allow Comments" choice. I don't see them in Settings > Options or the theme options. I see choices about comments but nothing that just shuts them down.

  4. 724shelties
    Posted 5 years ago #

    Heh, yanking the code from single.php worked. There are still references to comments on the page (near the title) but the form is off the page for now. Thanks alanchrishughes. I saved copies of that and page.php (for pages) when I put it back.

  5. alanchrishughes
    Posted 5 years ago #

    It is different for different themes, but it will say something like

    <?php comments_popup_link('No Comments', 'One Comment', '% Comments');?>

  6. alanchrishughes
    Posted 5 years ago #

    That will probably be in the index.php file. Some themes use a loop.php or front.php file though. If it shows up on the pages for the individual articles it will be in the single.php file.

Topic Closed

This topic has been closed to new replies.

About this Topic