WordPress.org

Support

Support » How-To and Troubleshooting » Turn off auto title correction?

Turn off auto title correction?

  • In 1.2 and 1.3.x when you created entries with the same name they would all show up on the same page.

    I was making use of that, and really enjoying it.

    Now in 1.5 when I add more, they are automatically appended with a “-2” and the number is incremental.

    How can i turn this feature off in WP1.5?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Are you talking about using the “next page” quicktag that set one post up into multiple pages? Or actually naming posts the same name? I believe by default the post title must be unique or it will cause problems.

    And as a user of web pages (aren’t we all), I want to know what pages I’m on in a series.

    And as far as I know, it did this in 1.2 for me and it does it by default in 1.5. I personally wouldn’t want it changed, but I’ll let someone else tell you how, and if it can be done.

    Here’s an example of what happened in 1.2 and 1.3b
    http://sunshine.dubtribe.com/how-to-win-my-heart/

    Here’s what happens now:
    http://sunshine.dubtribe.com/how-to-win-my-heart-3/

    The “-3” in the permalink is automatically added by WP and won’t go away.

    The next post is added as “-4” etc…

    I’d love to change this back, and enjoy continued additions to my special sections.

    ah well…

    back to the drawing board.

    I’m having a problem with the change, but for a slightly different reason. In 1.2, I could use the same post slug on different days — for example:

    /2005/03/01/slug/
    /2005/03/05/slug/
    /2005/04/02/slug/

    This was handy for repeated “theme” posts. It also meant you didn’t have to remember every slug you’ve ever used; just those on the same day.

    It was fixed after this bug report, on the basis that posts’ URIs should not be allowed to clash (by default).

    That means I’m now forced to do this:

    /2005/03/01/slug/
    /2005/03/05/slug-1/
    /2005/04/02/slug-2/

    I don’t like it, and I’ve been manually editing the database to put it back the way it was.

    At the end of that bug report, Matt said he would look at comparing the permalinks rather than the slugs. This would solve my problem whilst avoiding the original bug that was reported.

    Is there any word on progress? If Matt’s too busy, is there anyone who would volunteer to look at it for me? I’d greatly appreciate it.

    This is essentially the same issue, the difference is the use of the permalink structure. I use the title only, and not the date.

    but it’s the slug which is breaking the collected themes.

    /slug/
    /slug-1/
    /slug-2/

    precisely.

    I would like to either help with a plugin to allow themed entries (which stack when you click the permalink)

    Or find out how to put this part of the code back to what was possible in 1.2

    If you just want to swap back to what was in 1.2, I’m pretty sure you just need to edit wp-admin/post.php and delete the section of code outlined at the end of this file.

    Very interesting.

    Thank you. I’ll write up my results.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Turn off auto title correction?’ is closed to new replies.