Support » Plugin: Widgets on Pages » Turbo Sidebars no longer appearing on Widgets page

  • Resolved davidkneale

    (@davidkneale)


    Hi there.
    I just upgraded from 0.0.12 to 1.4.0. This rendered all of my 110 on-page widgets inactive, but its a bit upgrade so I understand that, and have dragged most across to reactivate them.

    The problem I’m having is that quite a few of the Turbo Sidebar items are no longer appearing in the Widgets section. Only 99 of the sidebars are appearing instead of the 110 that are set up. This wasn’t a problem previously.

    Do you know a way that I can fix this so all of them appear?

    Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Hi @davidkneale,

    Firstly apologies that you had to reconfigure the widgets after the upgrade. Gong to 1.0.0 was a big jump architecturally and sadly i couldn’t make it so that the widgets would migrate in all cases.

    As for your issue I have now limited the number of sidebars shown to aid performance. Looks like I mis-assumed how many would be in use.

    If I could get an update out that allowed this limit to be increased would that suit your needs, do you think?

    I shall also have a think to see if I can work out a way to optimise without the setting being needed, but that may take longer than just adding a temporary setting for users like you.

    Thoughts welcome.

    davidkneale

    (@davidkneale)

    Hi.
    Thank you for your very quick reply. If you could get an update out that would allow for 120 sidebars that would be great! As I said I have 110 sidebars that I’ve created and they all appear within the Turbo Sidebars configuration area, it’s just that only 99 appear in the widgets editing panel.

    Let me know how you go with the update. Thanks again.

    [ Please do not bump. ]

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Hi @davidkneale

    I haven’t got around to this yet, sorry.
    If you’re happy to make a change to a PHP file you could alter the /admin/class-widgets-on-pages-admin.php file. This has a line like this;

    		$args = array( 'post_type' => 'turbo-sidebar-cpt', 'posts_per_page' => 100 );
    

    You should be able to just update the 100 to a bigger number, as a temporary work-around.

    Todd

    davidkneale

    (@davidkneale)

    Unfortunately I couldn’t locate that line. Instead I updated the following in the file you mentioned:

            check_ajax_referer( 'twd-nonce', 'security' );
            $list = array();
            $args = array(
                'post_type'      => 'turbo-sidebar-cpt',
                'posts_per_page' => 120,

    and

            $args = array(
                'post_type'      => 'turbo-sidebar-cpt',
                'posts_per_page' => 120,
            );

    This seems to have done the trick. It seems to be working ok, but could you please confirm that this won’t break the plugin?

    Thank you.

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    That should do the trick, and shouldn’t have any detrimental effect at all. Nice one.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.