WordPress.org

Forums

Really Simple Share
[resolved] Tumblr button not showing? (7 posts)

  1. pixelkicks
    Member
    Posted 2 years ago #

    I'm testing out using the Tumblr share button on our site as we have a really young audience where Tumblr is massively popular.

    However, the button isn't displaying and when I check the code I get the following:

    <a href="https://www.tumblr.com/share/link?url=http%3A%2F%2Fwww.onedirection.net%2F1d-sign-an-all-4-one-and-one-4-all-3-year-contract%2F&name=1D%20Sign%20An%20%E2%80%9CALL%204%20ONE%20AND%20ONE%204%20ALL%E2%80%9D%203%20Year%20Contract" title="Share on Tumblr" style="display:inline-block; text-indent:-9999px; overflow:hidden; width:61px; height:20px; background:url('http://platform.tumblr.com/v1/share_2.png' rel=" prettyphoto[7968]")="" top="" left="" no-repeat="" transparent;"="">Share on Tumblr</a>

    Chrome developer tools report the background css line to be invalid, and thus the image doesn't show.

    Is there a fix for this?

    http://wordpress.org/extend/plugins/really-simple-facebook-twitter-share-buttons/

  2. whiletrue
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,
    the Tumblr button looks good on our test sites with the same code. You can try to check the "Load scripts at the bottom of the body" option in the "Settings -> Really simple share" advanced options box. If it doesn't work, please tell us your site url to perform some checks.

  3. pixelkicks
    Member
    Posted 2 years ago #

    Hi,

    I already have the "Load scripts at bottom" checked. I've just enabled the Tumblr button on this page only (rest of site is cached):

    http://www.onedirection.net/latest-have-haylor-split-after-holiday-argument/

    Appreciate it if you could take a look.

    Thanks, Chris.

  4. whiletrue
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Chris,
    I've looked at the page source code, it seems like a PrettyPhoto plugin or theme function or similar is adding wrong code to the image button; can you check this? In case, try to disable or limit the scope of that plugin.

  5. pixelkicks
    Member
    Posted 2 years ago #

    Ok I'll have a look... Cheers.

  6. pixelkicks
    Member
    Posted 2 years ago #

    This is really odd, but I don't have PrettyPhoto enabled on the site. Searching the code for PrettyPhoto only brings back to the one occurence, on the Tumblr image.

    Any idea what could be adding the code?

  7. pixelkicks
    Member
    Posted 2 years ago #

    Doh, no sooner did I send this email then I found the culprit.

    The WordPress theme I've amended had some custom code in its functions.php to add the rel tag to images. I've never noticed this before.

    Stripped it out now. Works fine!

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Really Simple Share
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags