Support » Theme: Twenty Twenty-Two » [NSFW] TT2 seems to brake the jquery code

  • Resolved fbarthelemy

    (@fbarthelemy)


    Hi,
    Le TT2 theme seems to brake the jquery code.
    “ultimate Addons for Gutenberg”, and “GeoDirectory” maps are broken with the TT2 Them.

    Js error :
    `Uncaught TypeError: Cannot read properties of undefined (reading ‘indexOf’)
    at map_ajax_search (map.min.js?ver=2.1.1.13:1:11793)
    at build_map_ajax_search_param (map.min.js?ver=2.1.1.13:1:9625)
    at HTMLDocument.<anonymous> ((index):594:4)
    at e (jquery.min.js:2:30038)’

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi there — If you haven’t already, you should consider reaching out to the authors of those plugins. Twenty Twenty-Two doesn’t include any JavaScript itself, so it’s likely that the issue here lies in these plugins’ compatibility with WordPress 5.9 and block themes in general.

    Thread Starter fbarthelemy

    (@fbarthelemy)

    So, I reach out to the authors of those plugins.
    Thanks a lot !
    This FSE version is very crazy ! 🙂

    • This reply was modified 10 months, 1 week ago by fbarthelemy.
    Thread Starter fbarthelemy

    (@fbarthelemy)

    But….
    A search on forum gives me this :
    TT2 have issue executing wp_localize_script() from the widget/block.
    And some plugins uses this.
    Here someone reported same issue https://github.com/WordPress/twentytwentytwo/issues/302

    What do you recommand ?

    Thanks for sharing that other thread. Yes, the issue is similar, but like your report above, it’s not necessarily an issue with Twenty Twenty-Two — it appears to be a conflict with all block themes, and would need to be solved in WordPress itself, or in the plugins individually. I’d recommend waiting for the plugin authors to address the issue.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[NSFW] TT2 seems to brake the jquery code’ is closed to new replies.